Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to setup OpenLDap. I am really unsure what I am doing and don't wish to post a general help me question without an answer. I am interesting in getting more detailed log files so I can track down my problems.

when I run: sudo ldapsearch -x -d8

I get: ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

when I run: sudo ldapsearch -x -d8 -v

I get:

ldap_initialize( <DEFAULT> )
ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

If have seen this but I don't have the file /etc/syslog.conf but modifying my rsyslog.conf in a similar way does nothing.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It looks like you haven't specified a host or URI at all. ldapsearch can't contact the server because one hasn't been provided.

  • The openldap binaries do not currently support service discovery.
  • The openldap client binaries binaries don't log.
  • There is nothing to indicated that you are using SSL/TLS.
  • You don't need sudo to do a search unless you're trying to be gidNumber=0+uidNumber=0,cn=peercred,cn=external,cn=auth, in which case your URI should be ldapi:///.
share|improve this answer
    
So my answer is user input errors are not logged on the server level. Do appreciate the help. Updated the question in hopes that somebody else can use this useful information. –  DarkSheep Feb 12 '13 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.