Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to use Thunderbird with Exchange 2007. Before I used Outlook and everything worked fine. Now I set up the following settings in Thunderbird:

Inbox
IMAP
Server Address: 192.168.0.1
Port: 143
SSL: STARTTLS
Authentication: Password, normal

Outbox
SMTP
Server Address: 192.168.0.1
Port: 587
SSL: No
Authentication: No

The user can send and receive emails from inside the organization. Now the user should also send and receive emails outside the organization. If the user tries it he gets Unable to relay and no message is sent. This is an authentication problem.

How should the Exchange 2007 server be configured?

I tried other settings for the outbox within Thunderbird but they didn't worked. In the Exchange management consonsole I go to server configuration, client access, POP3 and IMAP4, click on the properties of POP3 and I have the following settings:

Binding:
TLS: Port 110
SSL: Port 995

Authentication:
Secure login and the name of the X.509 certificate

Under server configuration, Hub-Transport, properties of the default connector, tab authentication TLS, basic authentication and integrated Windows authentication is checked. Under authorisation group anonym user, exchange user, exchange server and legacy exchange server is checked.

share|improve this question
    
Thunderbird + Microsoft Exchange is a pretty poor experience in my opinion... However, you should be able to get this to work. Why are you using IP addresses instead of hostnames? –  ewwhite Feb 7 '13 at 11:12
    
@ewwhite: Yeah I know ... I looked for configurations which I found in the net and there somebody used the IP address. But I didn't get it managed to work with mail.yourdomain.com in the server address settings for IMAP and SMTP ... –  testing Feb 7 '13 at 11:17

1 Answer 1

SMTP should be configured to require authentication if you are publicly exposing the ports. Most default configs only allow relaying as authenticated users.

By "outside the org" are you leaving the network? Are you using VPN to connect to 192.168.0.1? mail.yourdomain.com is probably resolving to a public IP address, which would be unreachable while you are inside the network, and would only work outside the firewall if you had your IMAP/SMTP ports open to the Exchange server.

I think that if you were to configure your client to authenticate against both IMAP and SMTP, you would at minimum be working inside your firewall, pointed at 192.168.0.1.

To get it working outside the firewall with a local address, you would need to VPN.

If you don't want to VPN, and want to use mail.yourdomain.com, you could setup the yourdomain.com zone on an internal DNS server (assigned to clients with DHCP) and have it resolve mail.yourdomain.com to 192.168.0.1, and when you are outside the firewall, public DNS would resolve it to the correct public IP.

share|improve this answer
    
With "outside the org" I mean that the user can send to a gmail account not only to a mail account in the domain. So I'm in the network. There is an authentication for the incoming mails but there is no authentication for sending the emails. I tried to set up authentication in Thunderbird but it didn't worked. So how do I have to configure the authentication on the E2K7 server? –  testing Feb 13 '13 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.