Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Linux 2.6.18-164.11.1.el5.centos.plus filesystem in question: reiserfs

Hi,

I'm having trouble deleting a file:

[root@flat: all_subjs_wcbf]# ls -lah
total 0
drwxrwxrwx 2 szhu cfn 88 Sep  1  2011 ./
drwxrwxrwx 3 szhu cfn 80 Jun  8  2011 ../
?--------- ? ?    ?    ?            ? sub13_AVG_5_cbf.m

[root@flat: all_subjs_wcbf]# rm sub13_AVG_5_cbf.m 
rm: cannot lstat `sub13_AVG_5_cbf.m': Permission denied

Looking at other posts on serverfault and stackoverflow for suggestions:

  • the dir and containing dir's all have executable permission set, for all users. I've tried setting all containing dirs to 777 again at the same time just in case, but still cannot lstat.
  • there are no associated IO errors reported.

I've tried "rm -rf" and "rm -i" just in case. No luck.

I'll eventually pull the disk offline and check it, but want to put that off because it's heavily used. So if this is not a disk error and can be fixed now, it'd be a great help! Thanks.

-Michael

share|improve this question
    
See anything interesting in dmesg? –  ewwhite Feb 7 '13 at 19:34
    
Nothing I can see in dmesg, /var/log/dmesg or even /var/log/messages. I'm pretty new to all this so I could be missing something, but not too likely. –  Michael S Feb 7 '13 at 22:09

1 Answer 1

This is a disk error, and you will need to take the disk offline and check it with reiserfsck.

share|improve this answer
    
OK, I'll take it down as soon as I can and let you know what reiserfsck comes up with. –  Michael S Feb 7 '13 at 22:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.