Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Firefox 18.0.2 on some thin clients with Windows 7 Embedded - basically locked down web kiosks for customer use.

The clients are write protected and all updates are disabled, but once things like Flash or Adobe Reader get out of date trying to access content results in a full page warning about it being out of date. Is there a way to either completely disable this check, or allow a global pass for all websites?

I am aware that I can add individual websites by clicking the icon in the location bar and telling it to always load plugins to that particular site, however this is unfortunately not an option.

The sites the clients have access to is controlled at a network level and occasionally new domains are registered and added - for instance if a promotion is on the marketing team will put up a new website with a new domain. If one of these has any flash or PDF content we will need to manually open the page on every single client and add an exception to avoid the warning.. not exactly ideal.

I have had a look in the about:permissions page and the only option there for plugins is 'Allow' or 'Always ask'. I have this set to allow but the above warning is not influenced by this. The about:config page has also come up dry.

If anyone has had any success with this or knows a setting I've missed help would be appreciated.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Solution discovered! Posting for anyone else who might need it as looks like the documentation is out of date.

  1. Open the about:config page by typing it into the address bar and accept the warning
  2. Search for the following option: Extensions.blocklist.enabled
  3. Toggle it to false by double clicking on it

This option is documented as a blacklist against known malicious extensions however it now also toggles the checking of plugins for vulnerabilities as well.

A warning: Turning this option to false lowers the security of your browser - not only will it stop checking for plugin vulnerabilities but Firefox will not prevent you from installing known malicious extensions that could hijack your browser or do any number of other nasty things.

The best solution when you see this message is to update the vulnerable plugin. I am only doing this because it is necessary and the kiosks where it will be used are heavily walled off from all but a handful of completely trusted sites.

Hope that saves someone else from all the searching I had to do!

Sources: https://support.mozilla.org/en-US/questions/949746 / http://kb.mozillazine.org/Extensions.blocklist.enabled

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.