Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an external USB hard drive attached to a Debian Squeeze server. /etc/fstab has the following in it:

 /dev/sdc1 /mnt/win ntfs-3g defaults 0 0

If I run mount -a then it mounts fine.

However, if I reboot, I get a console error saying:

ntfs-3g: Failed to access volume '/dev/sdc1': no such file or directory

Does anyone know why this is? At the moment, I'm having to put a mount -a in /etc/rc.local but I really don't want to do that.

share|improve this question
    
You should remove the line from the fstab. It will mount your USB drive using the UUID label. You can view it using blkid. Just remove the line and try again. –  val0x00ff Feb 8 '13 at 11:59
    
That was what I did at first (left it out of fstab), but it doesn't mount. blkid shows it's there, as /dev/sdc1. I can't see any clues in the logs - do I need to configure some mount daemon? An internal second HD (SATA) is being mounted on boot with and entry I put in fstab though. –  Gilgongo Feb 11 '13 at 10:49
    
Try to change the mountpoint of the /dev/sdc1. Put this into the fstab /dev/sdc1 /media/win ntfs-3g defaults,locale=en_US.utf8 0 0 Probably your USB port is being enabled later on by the kernel or the fuse module is being loaded later during boot. –  val0x00ff Feb 11 '13 at 11:14
    
Yesh - looks like there's some boot dependency not working out. The same thing happens if I change the mountpoint. What's odd is that this problem isn't more widely reported. Anyone who wants to re-mount an external NTFS drive on Debian would be hit by this, no? Right now, I'm just mounting it from rc.local, which works fine. I'll just put a comment in fstab about that and I hope that will be OK ongoing. Oh well. –  Gilgongo Feb 12 '13 at 14:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.