Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've appended these in my php.ini and still can't get any php errors to display

display_errors = on
display_startup_errors = on
error_reporting = E_ALL
html_errors = on
log_errors = on

here's a copy of my php.ini http://pastebin.com/Zf3LBJmQ

This is my first time using SSH to administer a server of any kind, thank you for taking the time to read this

So apprently there's two php.ini files? I had to edit this one:

/etc/php5/cli/php.ini

Now it works great!

share|improve this question
    
If you solved the problem, please post the answer for the benefit of others. Welcome to Server Fault! –  Michael Hampton Feb 10 '13 at 2:42
add comment

1 Answer

Did you restart apache after making these changes? Is your app perhaps using ini_set to override these settings?

share|improve this answer
    
yes i've restarted apache and I've been using just a quick php to make an error of any kind appear like: <?php if(x){ ?> and instead of getting an error in the browser, the page doesn't display at all. –  Silas Feb 9 '13 at 22:47
    
here's a copy of my .ini file pastebin.com/Zf3LBJmQ –  Silas Feb 9 '13 at 22:52
    
Ah, that explains, you just added some values at the bottom. Those settings are set earlier in the file as well and the first one wins. –  Dennis Kaarsemaker Feb 9 '13 at 23:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.