Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have really annoying problem with Bind and Cent OS, latest version of bind.

When I try to start it:

Error in named configuration:
zone localdomain/IN: loaded serial 42
zone localhost/IN: loaded serial 42
zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 1997022700
zone 255.in-addr.arpa/IN: loaded serial 42
zone 0.in-addr.arpa/IN: loaded serial 42
/var/named/sites/x7-hosting.org.db:3: no current owner name
/var/named/sites/x7-hosting.org.db:4: no current owner name
/var/named/sites/x7-hosting.org.db:11: no current owner name
/var/named/sites/x7-hosting.org.db:12: no current owner name
/var/named/sites/x7-hosting.org.db:13: no current owner name
/var/named/sites/x7-hosting.org.db:14: no current owner name
/var/named/sites/x7-hosting.org.db:15: no current owner name
/var/named/sites/x7-hosting.org.db:16: no current owner name
/var/named/sites/x7-hosting.org.db:17: no current owner name
/var/named/sites/x7-hosting.org.db:18: no current owner name
/var/named/sites/x7-hosting.org.db:19: no current owner name
/var/named/sites/x7-hosting.org.db:20: no current owner name
/var/named/sites/x7-hosting.org.db:21: no current owner name
zone x7-hosting.org/IN: loading master file /var/named/sites/x7-hosting.org.db: no owner
_default/x7-hosting.org/IN: no owner

This is myx7-hosting.org.db file:

$ORIGIN x7-hosting.org.
    $TTL 14400
    @       IN      SOA     ns1.x7-hosting.org.     root.x7-hosting.org. (
                2013010802      ; serial, todays date+todays
                86400           ; refresh, seconds
                7200            ; retry, seconds
                3600000         ; expire, seconds
                86400 )         ; minimum, seconds

    x7-hosting.org.                86400   IN      NS      ns1.x7-hosting.org.
    x7-hosting.org.                86400   IN      NS      ns2.x7-hosting.org.
    ns1.x7-hosting.org.            14400   IN      A       91.193.75.81
    ns2.x7-hosting.org.            14400   IN      A       91.193.75.81
    x7-hosting.org.                14400   IN      A       91.193.75.81
    localhost.x7-hosting.org.      14400   IN      A       127.0.0.1
    x7-hosting.org.                14400   IN      MX      0 x7-hosting.org.
    www                          14400   IN      CNAME   x7-hosting.org.
    ftp                          14400   IN      CNAME   x7-hosting.org.
    mail                         14400   IN      CNAME   x7-hosting.org.
    webmail                      14400   IN      CNAME   x7-hosting.org.

This is my named.conf

    // MAINTAINED BY [LUKA PAUNOVIC]
// Began [10.02.2013]

include "/etc/rndc.key";

controls {
        inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };
};

options {
        allow-transfer { 127.0.0.1; };
        allow-recursion { 91.193.75.81; };
        directory "/var/named";
        pid-file "/var/run/named/named.pid";
        dump-file "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        // query-source address * port 53;
};

//
// a caching only nameserver config
//

zone "." IN {
        type hint;
        file "/var/named/named.ca";
};

zone "localdomain" IN {
        type master;
        file "/var/named/localdomain.zone";
        allow-update { none; };
};

zone "localhost" IN {
        type master;
        file "/var/named/localhost.zone";
        allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
        type master;
        file "/var/named/named.local";
        allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
        type master;
        file "/var/named/named.ip6.local";
        allow-update { none; };
};

zone "255.in-addr.arpa" IN {
        type master;
        file "/var/named/named.broadcast";
        allow-update { none; };
};

zone "0.in-addr.arpa" IN {
        type master;
        file "/var/named/named.zero";
        allow-update { none; };
};

// LOCAL ZONES /////////////////////////////////////////////////////////////////
// your websites and other named-servers will go below here.
zone "x7-hosting.org" {
            type master;
            file "/var/named/sites/x7-hosting.org.db";
    };
share|improve this question

1 Answer 1

Remove the leading whitespace from (at least) the first few lines of the file.

share|improve this answer
    
I do not have whitespaces on the top of the file... –  Luka Feb 11 '13 at 18:54
    
Then please edit your question to reflect the actual state of the file. –  Michael Hampton Feb 11 '13 at 19:41
    
Where do you see blank line at top of myx7-hosting.org.db file o.O –  Luka Feb 11 '13 at 20:45
    
@Luka - whitespace does not just mean blank lines, it also means indenting –  Mark Henderson Feb 11 '13 at 21:03
    
I do not care, I installed Kloxo, this is annoying. –  Luka Feb 11 '13 at 21:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.