Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to run php-fpm on my Centos VPS but when I get to php-fpm part I get an error.

I downloaded packages from these links:

rpm --import
rpm -ivh

Then after all the other services went fine I tried this command:

yum install php php-fpm mod_fastcgi
Loaded plugins: priorities, refresh-packagekit
1360 packages excluded due to repository priority protections
Setting up Install Process
Package php-5.3.3-14.el6_3.i686 already installed and latest version
No package php-fpm available.
Package mod_fastcgi-2.4.6-2.el6.rf.i686 already installed and latest version
Nothing to do

Enable php-fpm

chkconfig --levels 235 php-fpm on
error reading information on service php-fpm: No such file or directory

For some reason I have package php-5.3.3-14.el6_3.i686` already installed and latest version but I should be having


I tried downloading package from this link but when repeating the process I got the same results. So why can't I run the php-fpm services?

P.S. I tried even with

services php5-fpm start

No luck.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Install the remi-release RPM from the remi repository.

You must also edit the /etc/yum.repos.d/remi.repo that it installs, in order to enable the repo. Find the [remi] section and change enabled=0 to enabled=1.

Then you can use the packages the repository provides.

share|improve this answer
If you think of this rpm --import rpm -ivh I already didi it. Also check out this – IceD Feb 10 '13 at 23:29
I've noticed that I don't have [epel] section in my repo . And this tutorial says it should be there. – IceD Feb 10 '13 at 23:52
You wouldn't have an EPEL section in the remi repo! It's in the epel repo. – Michael Hampton Feb 10 '13 at 23:55
Yeah I got it now when I looked in my Putty. This is my epel.repo And this is my remi.repo – IceD Feb 10 '13 at 23:56
OK, you're done. Now you can install your packages. – Michael Hampton Feb 10 '13 at 23:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.