Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm installing the developer edition of SQL Server 2008 and it's giving me the error:

"A previous release of Microsoft Visual Studio 2008 is installed on this computer. Upgrade Microsoft VS2008 to the SP1 before installing SQL Server 2008."

Except that I already have VS2008SP1 installed. Anyone know what else it might be referring to?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Do you have the Web Developer installed? This article describes a situation where this can arise

Also if you installed any pre-release or beta versions of any of these components, this could cause problems and they should be uninstalled and the released versions installed.

share|improve this answer
    
I'm in the process of removing anything that looks suspicious. We'll see if that does it. –  scottmarlowe Jul 29 '09 at 20:33
    
Looks like I'm off and running. It was one of the SQL installs put there by VS2008. I removed everything that had "SQL" in it, though this post (stackoverflow.com/questions/844945/…) indicated the VS2008 Shell was the culprit. –  scottmarlowe Jul 29 '09 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.