Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Hamachi on CentOS 6.3 (64-bit), but the network interface never appears. I installed from the official Hamachi RPMs:

sudo rpm -ihv logmein-hamachi-2.1.0.86-1.x86_64.rpm

Installation appears to succeed:

Preparing...                ########################################### [100%]
   1:logmein-hamachi        ########################################### [100%]
install_initd ok.
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachi[  OK  ]

I am able to use the Hamachi client to join networks, and I even see this new server in the network I joined in the peer list on other clients. Connection is green, with a direction connection to all peers in the network. However, I am unable to actually send any data over Hamachi.

The problem is that the network interface doesn't exist. When I run ifconfig, I only see the usual interfaces. ham0 is not listed, like it is on my Ubuntu boxes. No interface has my Hamachi IP address assigned.

I have tried forcing the reinstall of the RPM, restarting the daemon, and restarting the box. How can I get the ham0 interface to install?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

The problem turned out to be that the TUN/TAP driver was not enabled. Running modprobe tun was unable to load it.

This server was a VPS hosted under OpenVZ. As suggested by another post, I had my VPS host enable the TUN/TAP driver, restarted the Hamachi daemon, and all was well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.