Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are running an exchange 2010 server. Everything was working fine till this morning. No changes have been made to the server.

The problem we are having is in recieving external email. We are not recieving anything from external accounts. I have run a test using and recieve:

Testing inbound SMTP mail flow for domain 
  ExRCA failed to test inbound SMTP mail flow. 

 Test Steps 

 Attempting to retrieve DNS MX records for domain 
  One or more MX records were successfully retrieved from DNS. 

 Testing Mail Exchanger 
  One or more SMTP tests failed for this Mail Exchanger. 

 Test Steps 

 Attempting to resolve the host name in DNS. 
  The host name resolved successfully. 

 Testing TCP port 25 on host to ensure it's listening and open. 
  The port was opened successfully. 

 Attempting to send a test e-mail message to using MX 
  Delivery of the test message failed. 

 Additional Details 
 The server returned status code -1 - The operation has timed out.
Exception details:
Message: The operation has timed out.
Type: System.Net.Mail.SmtpException
Stack trace:
 at System.Net.Mail.SmtpClient.Send(MailMessage message)
 at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()

When I try using Telnet from a remote network I get the following:

telnet 25

220 Microsoft ESMTP MAIL Service ready at Mon, 11 Feb 2013 12:20:09 + 1100
250 Hello []
mail from:
250 2.1.0 Sender OK
rcpt to:
250 2.1.5 Recipient OK
354 Start mail input; end with <CRLF>.<CRLF>

and then it just hangs. I'm not sure if I'm ending the data section wrongly, but whatever I type in there Telnet does not send a response. As you can see, is getting the same result so I don't think it's something I'm doing wrong.

I've checked the server, there are no errors in the event log. We did have a disk space issue a few weeks ago, but there is still 1.5GB free on the exchange drive. We have installed HUB Transport on another server and have pointed SMTP to it and it is working, but this is not ideal for us.

What else can I do to make our primary hub transport exchange service recieve emails?

share|improve this question
I've tried following the steps here: but still nothing when I press enter.enter at the end of data. When I type QUIT<enter> telnet just sits there doing nothing – Greg Feb 11 '13 at 1:36

1.5GB may not be enough free space...

  • Have you restarted Exchange services?
  • Have you rebooted the server?
  • Can you check your Exchange mail queues (EMS->Toolbox->Queue Viewer)?
share|improve this answer
Tried rebooting server. Checked the exchange mail queues and they are empty. Just found some errors in the event viewer. Updating the question now – Greg Feb 11 '13 at 1:41
We thought about the disk size as well. The current mailbox database is only 2GB, with 1.5GB free on that drive (it's the only thing on that partition) so we don't think that is the problem. – Greg Feb 11 '13 at 1:59
up vote 0 down vote accepted

Turns out that .NET 4.5 was installed on the mailbox server while the Client Access & Hub Transport server had not been updated.

On updating the CAS/HUB Server to 4.5 everything now works. I'm not sure why the problem but this seems to fix it.

Our setup is:

Server 1            Server 2
Mailbox             CAS & HUB Roles

As mentioned in one of my updates we installed the HUB role on Server 1 and this resolved the issue. On Updating to .NET 4.5 on both servers we can go back to our original setup.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.