Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In a fresh installation of CenotOS 6 in a VPS after running sysctl -p /etc/sysctl.conf I got this errors:

error: "net.bridge.bridge-nf-call-ip6tables" is an unknown key
error: "net.bridge.bridge-nf-call-iptables" is an unknown key
error: "net.bridge.bridge-nf-call-arptables" is an unknown key

What is the starting point to solving this errors?

share|improve this question
1  
Are they really a problem - I have the same errors on a CentOS 6 system which appears to work fine. –  Iain Feb 11 '13 at 18:09

4 Answers 4

up vote 3 down vote accepted

You mention in your question that you are using a VPS. What kind of VPS? It sounds like you are in a OpenVZ VPS. If it is OpenVZ, it is sharing the kernel among many containers like yours and you cannot change the kernel configuration per container but directly on the host. I actually build a litlle OpenVZ centos container and I tried to apply the kernel config net.bridge.bridge-nf-call-ip6tables = 0 followed by sysctl -p and I got the same error as you do. If you really need it, that means you may have to think about changing the type of virtualization you are using or you may try to contact your VPS provider and ask him to enable this setting.

Best.

share|improve this answer
    
I just try tuning my VPS and during the process I got this error, I don't know what are them. and if removing those line is a safe way to remove errors, I will do. –  Mohammad Ali Akbari Feb 11 '13 at 20:39
1  
It is not about removing these line they were in my VPS configuration too, but if you want them to be applied, if you are running on a OpenVZ virtualization, you have to ask the owner of the server to activate these settings on the host not on the container. Best. –  drivard Feb 12 '13 at 21:27

There are several bugreports about this on Red Hat Bugzilla, for example here, here and here.

Just remove the lines or run sysctl -e -p instead of sysctl -p.

share|improve this answer

Try:

modprobe bridge
lsmod | grep bridge

You don't the those modules loaded into the kernel.

share|improve this answer
    
What is this module? should I load it? My server works fine with this errors without loading this module. –  Mohammad Ali Akbari Feb 11 '13 at 18:38
    
If you don't need the bridge, you can just ignore the entries/warnings –  Tiffany Walker Feb 11 '13 at 19:36

You get the errors because you do not have the bridge kernel module loaded. Three choices:

  1. Load the module if you need it
  2. Comment those lines out from /etc/sysctl.conf
  3. Let sysctl ignore the errors by giving it the -e flag.
share|improve this answer
1  
The problem I have had is that those entries are present in /etc/sysctl.conf even when the bridge module isn't loaded, which it isn't by default. Probably added by the rpm installed. I have a puppet module which removes those entries so we don't get the errors anymore. –  lsd Feb 11 '13 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.