Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Following this as a guide:

I've tried the following commmands:

svnadmin hotcopy "C:\Repositories" > "C:\BackupSVN"

svnadmin hotcopy "C:\Repositories\*" > "C:\BackupSVN"

svnadmin hotcopy "C:\Repositories\TestRepo1" > "C:\BackupSVN"

However all 3 commands result in "Access is denied"

I've tried them at an "Administrator" command prompt as well, still the same error.


How can I properly run an svnadmin hotcopy command (or even svnadmin dump) on a Windows 2012 server? What am I missing?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Grrr...I figured it out. Stupid default UAC on Windows 2012.

Deactivating UAC in Windows 2008 R2 was possible via running msconfig (for example winkey+r -> msconfig), going to the Tools tab and launching "Change UAC settings". There, you select "Never notify" to disable UAC. The same approach is still available in Windows Server 2012, though UAC is still active after you selected "Never notify". You have the option to turn off UAC via registry by changing the DWORD "EnableLUA" from 1 to 0 in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system". You will get a notification that a reboot is required. After the reboot, UAC is disabled.

UAC dialog

UAC regedit


share|improve this answer
What is UAC and how did you solved the UAC? – Syed Haider Hassan May 6 '13 at 11:42
@SyedHaiderHassan - I'll update my answer with details. – TheCleaner May 6 '13 at 13:08
@AlbertoSpelta - not sure what you are talking about. This question was about getting the command to run properly (which I did), not about what "hotcopy" does. Not sure why you even posted a comment here. – TheCleaner Jan 2 '14 at 17:25
Alternatively you can just run the "svnadmin hotcopy" as Administrator (run it from cmd.exe or PowerShell that was run as Administrator). Disabling UAC is pretty drastic IMO. – dangph Oct 21 at 6:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.