Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

we have a website with a SMTP server (Postfix) we used for almost a year. From about yesterday we keep getting the following error when sending emails to hotmail destinations:

Feb 12 10:52:34 CentOS-60-64-minimal postfix/smtpd[1975]: NOQUEUE: reject: RCPT from[]: 554 5.7.1 <>: Relay access denied; from=<> to=<> proto=ESMTP helo=<>

I'd like to highlight that we successfully sent email to hotmail addresses since yesterday, but now, without we changed anything on our postfix server, we keep getting this error. I also want to say that we successfully send emails to other domains (e.g.

Any idea on what could be causing this issue? There could be some configuration we could tune to fix it or at least investigate about it?


share|improve this question
up vote 0 down vote accepted

Check /etc/postfix/ file and/or your script.

mynetworks probably contains only

And you tried to connect from your external ip "RCPT from[]".

Changing connection string to probably changed your source IP also to

share|improve this answer
You're right, we have only And probably this is the reason why it's working now. But I still wonder why the old connection string did work until yesterday.. – lorenzo.marcon Feb 12 '13 at 13:38
Something was changed in your script or in your server configuration. It could be dns or /etc/hosts if you use hostname in your script. Also it could be a change in one of the components/programs you use in your script. – Laurentiu Roescu Feb 12 '13 at 13:48

Your IP is listed on at least one blacklist (see this) and it's possible that Hotmail considers this reason enough to block you outright.

share|improve this answer
We checked on the service you provided, and there is only one blacklist that lists us (, which apparently created an entry for our IP on march 2012. According to yot link, it seems that this blacklist service (apews) is not that much reliable.. but thanks anyway – lorenzo.marcon Feb 12 '13 at 10:32

SMTP Code 554. 5.7.1 is basically a rejection from the Recipient Domain

Cause IP has been included in a Real-Time Blacklist due to there is Spam coming from your Domain. You Domain/IP has been blacklisted by the recipient.

Check the standard recommendations at:

share|improve this answer

We solved by changing on the email sending scripts the connection string to the SMTP to: I can't explain exactly why, by the way. But it works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.