Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2003 SBS server running on a DL380 with 2 LAN cards as follows: 192.168.2.2 = LAN 100mb / 192.168.10.1 = copy subnet 1000mb

I have a Windows 2008 standard server running on another DL380 with 2 LAN cards as follows: 192.168.2.3 = LAN 100mb / 192.168.10.2 = copy subnet 1000mb

When copying files between the servers via \192.168.10.1 copy / paste, the server defaults to using the other 100mb nics and is slow at copying large amounts of data. How can i force the server to make use of the crossover cable and copy subnet that ive set up?

Ive got a large amount of data to copy before the morning so any help would be good.

Please note i dont have physical access to the servers right now only ILO and RDP

Cheers

share|improve this question
    
are you addressing the servers via their IP, or the computer name? –  Posipiet Jul 29 '09 at 22:07
    
Hiya, Thanks for your prompt response. I am accessing the servers shares via the IP... so clicking start - run - typing the server 192.168.10.x ip address and pressing enter. The shares pop up okay however if i load task manager on both servers and put it on the networking tab.. the only bandwidth used is LAN connection 1 and not LAN connection 2 (which is the quick connection running at gigabit). I was wondering about a route command or some software utility that lets you specify source lan card to copy from... –  user14930 Jul 29 '09 at 22:16
    
try mounting the share explicitely: net use * \\192.168.10.2\share –  Posipiet Jul 29 '09 at 22:19
    
That wouldn't force the traffic via a specific nic. The solution with the crossover cable between the 2 servers will not use a default gateway, so the 'route' command will not help –  Techboy Jul 29 '09 at 22:25

4 Answers 4

Mount the other server´s shares by explicitly with "net use * \\192.168.10.2\share".

Copy using the resulting drive letter, probably Z:.

Use robocopy to move the data: "robocopy d:\SharedDirectory z: /e /sec /r:1 /w:1".

Get robocopy from M$.

You can also set the 192.168.10.* addresses in the host file at %SystemRoot%\system32\drivers\etc\

share|improve this answer
    
That wouldn't force the traffic via a specific nic. –  Techboy Jul 29 '09 at 22:26
    
works for me with 2x win2003 server. –  Posipiet Jul 29 '09 at 22:31
    
ah, memories. At one point, at a customers I had to wire the servernames in the hosts file. –  Posipiet Jul 29 '09 at 22:32

That doesn't make sense. Windows should use the NIC that is bound to that IP subnet. I don't see how mounting the share explicitly or making a hosts entry (as Posipiet suggested) would have any impact on that.

To force that, you can do a route add as follows:

route add 192.168.10.0 255.255.255.0 192.168.10.1 metric 1 IF 1

...where 192.168.10.1 is the address of the static IP, and instead of "IF 1", you should put the interface number for that card. You can find the interface number by doing "route print" and looking at the interface list (far left number).

share|improve this answer
    
why add a route? If windows decides to use the 10.x IP address, it doesnt need a hint on how to go there. The point is making windows use that IP in the first place. –  Posipiet Jul 29 '09 at 23:38
    
Well the OP was already making windows use that IP. The point is that his system DOES need a hint on how to get there if it is taking the more expensive route –  Adam Brand Jul 30 '09 at 1:59
up vote 0 down vote accepted

I eventually managed to use ILO and disable the 192.168.2.x nics on both servers thus forcing it to use the 1gb connection which sped it up no end. I tried manually adding routes but this didnt work as you suggest and also the net use \192.168.10.x theory also didnt work. Whether accessing it via a mapped driver or just as a share on the fast subnet IP for some reason the server insisted on using the slower lan connection which was very strange. I think the route statement didnt work because as it was using a cross over cable the servers both had an ip and subnet and no gateway specified. Thanks for your help and if you have any ideas on how to do this in future i would still like to know. However for now the emergency is now over as of 6:30am this morning which was cutting things a bit fine.

Thanks

Martin

share|improve this answer

In a somewhat related aspect if you have large files to copy avoid using robocopy, it's very slow on multi gigabyte files, you can find out the exact reasons why at this post on the Windows Server Performance Team blog.

I now use Richcopy for large file copies and robocopy for quick and dirty copies at the CLI, I can't say I care for the way RichCopy handles the CLI...

share|improve this answer
    
thanks for your help –  user14930 Aug 1 '09 at 11:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.