Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using nginx without any problem on windows for the last few months. Today when I tried to start it up, I got this error:

nginx: [emerg] bind() to 0.0.0.0:80 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

Why did this start happening all of a sudden? I didn't change any configs or anything.

share|improve this question

closed as off topic by Michael Hampton, mdpc, Tom O'Connor, Khaled, Iain Feb 13 '13 at 9:39

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is this on a real server or is it on a workstation? – Iain Feb 13 '13 at 8:22
    
windows workstation – Dean Rather Feb 13 '13 at 9:26
    
In truth this is then probably a better for for Super User. – Iain Feb 13 '13 at 9:45
2  
Windows Web Server (IIS) may also cause this issue so try running: 'net stop WAS' to stop the service. Sometimes you may also need to run: 'net start W3SVC'. Note: Run cmd as admin. – Tom Hagen Jun 26 '15 at 18:28

Check Skype.

Skype automatically updated itself, and turned the "use port 80" option back on.

It's in settions->advanced.

share|improve this answer
4  
Unbelievable, but thanks. Tools > Options > Advanced > Connection – Tom Sep 12 '14 at 12:45
    
Sneaky M$. Very sneaky. – ddtpoison777 Jun 8 '15 at 6:27
    
Thank you.. been searching for solution. – demo.b Jul 4 '15 at 1:20
    
@Dean You are the man!! Thanks a lot!! – zur4ik Sep 2 '15 at 9:00
1  
I just installed skype for web (beta). It installed a separate plugin for video, which I assume has the same behaviour. If you have a skype for web tab open in your browser, you may need to close that. – murraybiscuit Feb 29 at 5:39

Check which ports are being used on your system.

There are some programs which bind port 80. For example TeamViewer, Skype, etc.

For an easy test type http://localhost in your browser and check which service appears.

Or ou can use a programm like CurrPorts by NirSoft.

share|improve this answer
    
In my case, it was IIS blocking port 80 - this appears to be a common problem. If netstat -o shows PID 4 listening on port 80, that's IIS. – mindplay.dk Mar 30 at 18:42

You can try run in CMD:

netstat -a | find "LISTENING"

also there was a piece of software called TCPView, which is very cool, and shows all runing process/occupied ports.

share|improve this answer
    
I used netstat -ao to also display the PID of the process blocking port 80 - then enabled the PID column in Task Manager to find out which process was blocking port 80. – mindplay.dk Mar 30 at 18:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.