Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am running debian squeeze. I want to install a previous version of postgresql. The current version in the postgres debian repository for 9.0 is 9.0.12. I specifically need to get 9.0.8.

How can I get version 9.0.8 installed on my machine?

share|improve this question
    
You really want all the bugs that were fixed between those two versions, including a number of security vulnerabilities? –  Michael Hampton Feb 13 '13 at 5:52
    
See my comment below regarding it being a business decision... –  slappyjam Feb 13 '13 at 6:06
    
It might be easier to fix the business process. –  Michael Hampton Feb 13 '13 at 6:10
    
Michael Hampton, obviously you've never worked at a software company and have had to deal with production. Why don't you try being helpful instead of making snarky comments. –  slappyjam Feb 13 '13 at 15:57
    
squeeze does not provide 9.0, it provides 8.4, while squeeze-backports has postgresql-9.0 (9.0.7-1~bpo60+1). I wonder where you get a 9.0.8 packaged for debian in the first place? –  Daniel Vérité Feb 14 '13 at 16:00

1 Answer 1

up vote 0 down vote accepted

If you want to get 9.0.8 installed....you'll first have to uninstall 9.0.12. I believe that 9.0.8 is not available in the repository, if it is ok, download and install it. Otherwise, you are going to have to do this from the sources and compile the binaries against your current OS configuration if you want things to work correctly.

I'm curious however, why you would want to backtrack to a previous version? The later versions generally have some serious bug fixes that you would want.

share|improve this answer
    
I need 9.0.8 because that's the last version that went through our company's QA cycle. It's a business decision, not a technical one. So there's no way to obtain 9.0.8 .deb files. I'm sure they existed at one point. Is there no way to access those? Building from source is something I'd rather avoid if at all possible. –  slappyjam Feb 13 '13 at 6:04
    
They might exist somewhere but probably not for the current OS configuration you are using at present. Thus they would likely be incompatible or have subtle problems due to the integration issues. –  mdpc Feb 13 '13 at 6:08
    
mdpc, thanks for the info. I reckon I'll have to suck it up and build from source. –  slappyjam Feb 13 '13 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.