Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm unable to install KB2746164 (Update Rollup 6 for Exchange Server 2010 Service Pack 2).

I've tried also a manual install (with elevated cmd prompt) but that didn't work either.

"Product: Microsoft Exchange Server - Update 'Update Rollup 6 for Exchange Server 2010 Service Pack 2 (KB2746164) 14.2.342.3' could not be installed. Error code 1603. Windows Installer can create logs to help troubleshoot issues with installing software packages. Use the following link for instructions on turning on logging support:"

"Installation Failure: Windows failed to install the following update with error 0x80070643: Update Rollup 6 for Exchange Server 2010 Service Pack 2 (KB2746164)."

Any ideas what I could do now?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

You could just go for Exchange 2010 SP3 which was released yesterday:

share|improve this answer
did that work for you? – juFo Feb 13 '13 at 16:03
I'm downloading SP3 now and will try to install it. Thanks for telling that SP3 is there. It was not yet available via Windows Update. Hope this works now :-) – juFo Feb 13 '13 at 16:19
installing SP3 just did the trick ;-) – juFo Feb 13 '13 at 21:56
  1. at powershell coomand prompt run Get-hotfix KB2506143 to confirm it is installed
  2. In control panel, Prgram and Features, select show updates
  3. Find update 2506143 and uninstall
  4. reboot
  5. rerun tol up 6 update
share|improve this answer
thanks but see the other answer. – juFo Feb 13 '13 at 21:57
For Windows 2008 SP2 environments, the update to uninstall is KB2506146 – Chris Driver Feb 14 '13 at 14:33

Just as an FYI for this. (Error 1603)

When you receive error 1603 in eventvwr following an MSI based install, you need to run the installer AS administrator, not just an account with the proper permissions.

In particular I see this w/ Exchange 2010, but anytime you have 1603, using an actual administrator account will fix your issue.

share|improve this answer

We are having a very similar fault. We managed to install it on one Exchange 2010 but for the other one we're getting the same error as you. We've also tried to install using the elevated command prompt and again like you we have no joy. We have looked around for some answers and can't find much other than here: Notice that under Prerequisites section the following: Note Remove all interim updates for Exchange Server 2010 SP2 before you apply this update rollup.

I didn't do this for our other Exchange 2010 server (which was the same build and update) and it installed on that without any problem. Anyway it might be worth giving this a try...

Well we've just tried that too but get the following error when trying to uninstall any of the previous update rollup packages for SP2: Setup Wizard for Update Rollup X-v2 for Exchange Server 2010 Service Pack 2 (KBxxxxx) ended prematurely.

So we are stuck....

share|improve this answer
the update starts but halfway I have rollback and it fails with the same message... – juFo Feb 13 '13 at 15:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.