Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On my old server I used php-xml to generate some xml sitemaps. On my new server I found out php-xml isn't installed. I did 'yum install php-xml' but I get the following error:

--> Running transaction check
---> Package php-common.i686 0:5.2.17-1.el6.art will be updated
--> Processing Dependency: php-common = 5.2.17-1.el6.art for package: php-mhash-5.2.17-1.el6.art.i686
---> Package php-devel.x86_64 0:5.2.17-1.el6.art will be updated
---> Package php-devel.x86_64 0:5.3.3-14.el6_3 will be an update
--> Finished Dependency Resolution
Error: Package: php-mhash-5.2.17-1.el6.art.i686 (@/php-mhash-5.2.17-1.el6.art.i686)
           Requires: php-common = 5.2.17-1.el6.art
           Removing: php-common-5.2.17-1.el6.art.i686 (@/php-common-5.2.17-1.el6.art.i686)
               php-common = 5.2.17-1.el6.art
           Updated By: php-common-5.3.3-14.el6_3.x86_64 (updates)
               php-common = 5.3.3-14.el6_3
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (base)
               php-common = 5.3.3-3.el6_2.8
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

What does this mean exactly? Do I need to install php-mhash first? Any help is much appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

For reasons I can't even begin to guess, your server is running an ancient and unsupported version of PHP from a third party repository (art? Never heard of it.) and the system wants to update PHP to the current version provided by Enterprise Linux.

Given that PHP 5.2 is past EOL and completely unsupported, you should have gotten rid of it long ago. Your best bet is to update the system to the current release of PHP shipped by EL (or a later version), and then install the additional packages you want.

share|improve this answer
    
Thanks for the advice, I will try to upgrade my PHP install first. I realize this might be too broad of a question, but my site allows image uploading and resizing through PHP/GD/Imagick do you think there might be any compatibility issues going from 5.2 to 5.3 or 5.4? –  Josh Mountain Feb 13 '13 at 22:20
    
Highly unlikely. Though of course you should upgrade your test server first... –  Michael Hampton Feb 13 '13 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.