Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Been running Server 2012 Hyper-V for a few months now quite reliably. That was until the following event started:

EventId 129 - Reset to device, \DeviceRaidPort0, was issued

When this occurs all VMs become completely unresponsive, cannot even shutdown so need to be forced off.

This particular VM (Server 2012) is using the virtual SCSI device driver with three dynamic .vhdx drives. I have checked the obvious and there is plenty of space for them all to expand into.

Found someone else with the same problem here.

It seems this maybe a (very serious) bug in the Hyper-V virtual SCSI driver.

Has anyone else encountered the same problem?

More importantly any suggested fix for this to get this server back up and running reliably?

This really is a very serious show-stopper, rather a shame because up to then hyper-v 2012 was looking quite good.

share|improve this question
    
This is not a VM Issue, this is a host / hardware level issue (i.e. the SCSI device does not respond, at one point the OS tries to wake it up with a reset. –  TomTom Jun 17 at 7:53

6 Answers 6

Yes, I am encountering this exact same problem. It only shows up on one of the VMs but it causes all VMs to start becoming unresponsive until the problematic VM is turned off. The general consensus is that it is a problem with the virtual SCSI controller and possibly dynamic disks. Attaching the virtual disk to a virtual IDE controller appears to prevent the problem from happening.

share|improve this answer

Thanks for the feedback otakuon, looks like we are not the only ones with this problem then. I have also reported this via the MS Partner program and am awaiting feedback from the virtual SCSI development team.

For the moment all is working again on our server and we are now using virtual SCSI driver again. Not sure which of these solved it but what we have done is:

  • Delete all temp files, defrag every drive/virtual drive on the system - this did not seem to help.
  • Uninstall: AMD Catalyst AMD Chipset Driver
  • Update Integration Services to latest version on all VMs - I suspect
    there was an Integration Services Update issued via Microsoft.
    Updates on the Hyper-V host but not also sent out to the clients via MS Update.

Perhaps one of the above solved the problem, or maybe just the wind changed direction! Either way just thought I would let you know how we got on in case this info help you.

share|improve this answer

Having the same issue here,

Did either of you manage to find the root cause of the problem? Running all the latest updates/hotfixes etc... still no luck.

http://social.technet.microsoft.com/Forums/windowsserver/en-US/e95631c6-c6b0-4dc8-a003-af4adbf113e9/windows-server-2012-can-occasionally-not-access-second-virtual-hard-drive-inside-a-vm?forum=winserverhyperv

share|improve this answer

Daniel,

No sorry still no answer from Microsoft. Apparently they passed this problem on to the relevant development team sixteen months ago and we are still waiting for a fix.

I recall talk of some elusive Microsoft hotfix kb2838669 but this links to Fix454614 for Windows 8! Microsoft would not answer if this was safe to install on Server 2012 or not.

Nick

share|improve this answer

Only suggestion I can think of is to ensure there are no VSS copies set to run on the partition containing the virtual machines.

There have been various hotfixes & updates suggested but no conclusive information fi any of these actually fix anything.

share|improve this answer

Microsoft suggest the following updates to fix this issue:

  • KB2920193
  • KB2916395
  • KB2867201
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.