Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Setting up a new server and having a few issues with postfix. Set it up using the same config as another server I have which works fine.

Anyway, when I try to send to a certain domain i keep getting

Feb 14 10:28:55 web postfix/smtp[6276]: B9056A041A: to=<>,[]:25, delay=0.29, delays=0.06/0.01/0.01/0.21, dsn=5.0.0, status=bounced (host[] said: 550 <www-data@kickseed.vpstest.local>: Sender address rejected: Domain not found (in reply to MAIL FROM command))

The MX records for the domain seem to be setup ok

Using dig on the domain I get the following.

; <<>> DiG 9.6-ESV-R4-P3 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32030
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

; IN  A


;; Query time: 36 msec
;; WHEN: Thu Feb 14 10:37:50 2013
;; MSG SIZE  rcvd: 67

My postfix config (postconf -n)

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
biff = no
config_directory = /etc/postfix
inet_interfaces = all
mailbox_size_limit = 0
mydestination =,, localhost
myhostname =
mynetworks = [::ffff:]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

---- Solution ----

Edited the file /etc/mailname and set it too the domain of the server ( and it sends correctly now. I assume it had been automatically filled with


when I used one of the short cuts to installing a LAMP enviroment on the server.

share|improve this question
kickseed.vpstest.local does not exists that's why you get 550 – user130370 Feb 14 '13 at 12:12
i have now changed the file that was providing the kickseed.vpstest.local domain. I have changed it but i'm still getting the same error just now for <> ? – cosmicsafari Feb 14 '13 at 12:53
up vote 0 down vote accepted

Make sure that your machine is configured to respond to the hostname, and ensure that hostname is correctly configured in DNS. Obviously the hostname is something different at the moment, so mail coming from you ends up coming from kickseed.vpstest.local.

share|improve this answer
I have already changed the hosts and hostname file and setup a reverse dns on the ip for the server. Where else could this kickseed be being set? – cosmicsafari Feb 14 '13 at 12:19
Probably in your web serving program, apache maybe? Spend the time to generate proper email headers in your mail script/form or make sure you're sending the right parameters to your local sendmail.. – NickW Feb 14 '13 at 12:20
OK well i tracked it down to /etc/mailname file and changed it to but its giving me the same error except <www-data@kickseed.vpstest.local> is replaced with <> – cosmicsafari Feb 14 '13 at 12:51
dig ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.5 <<>> ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 32941 ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ; IN A ;; Query time: 1744 msec ;; SERVER: ;; WHEN: Thu Feb 14 13:10:39 2013 ;; MSG SIZE rcvd: 43 – NickW Feb 14 '13 at 13:11
See that? You return no A record, you return no MX record, PLEASE go check your DNS. Unless it's a fake domain, which in that case, put the actual domain you're using.. – NickW Feb 14 '13 at 13:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.