Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Setting up a new server and having a few issues with postfix. Set it up using the same config as another server I have which works fine.

Anyway, when I try to send to a certain domain i keep getting

Feb 14 10:28:55 web postfix/smtp[6276]: B9056A041A: to=<enquiries@innovative-payroll.com>, relay=mailserver.innovative-payroll.com[213.171.216.114]:25, delay=0.29, delays=0.06/0.01/0.01/0.21, dsn=5.0.0, status=bounced (host mailserver.innovative-payroll.com[213.171.216.114] said: 550 <www-data@kickseed.vpstest.local>: Sender address rejected: Domain not found (in reply to MAIL FROM command))

The MX records for the innovative-payroll.com domain seem to be setup ok

Using dig on the domain I get the following.

; <<>> DiG 9.6-ESV-R4-P3 <<>> mailserver.innovative-payroll.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32030
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mailserver.innovative-payroll.com. IN  A

;; ANSWER SECTION:
mailserver.innovative-payroll.com. 3600 IN A    213.171.216.114

;; Query time: 36 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Thu Feb 14 10:37:50 2013
;; MSG SIZE  rcvd: 67

My postfix config (postconf -n)

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
biff = no
config_directory = /etc/postfix
inet_interfaces = all
mailbox_size_limit = 0
mydestination = web.hoodoowebdesign.co.uk, localhost.hoodoowebdesign.co.uk, localhost
myhostname = web.hoodoowebdesign.co.uk
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes

---- Solution ----

Edited the file /etc/mailname and set it too the domain of the server (hoodoowebdesign.co.uk) and it sends correctly now. I assume it had been automatically filled with

kickseed.vpstest.local

when I used one of the short cuts to installing a LAMP enviroment on the server.

share|improve this question
1  
kickseed.vpstest.local does not exists that's why you get 550 –  Eric DANNIELOU Feb 14 '13 at 12:12
    
i have now changed the file that was providing the kickseed.vpstest.local domain. I have changed it but i'm still getting the same error just now for <www-data@web.hoodoowebdesign.co.uk> ? –  cosmicsafari Feb 14 '13 at 12:53
add comment

1 Answer

up vote 0 down vote accepted

Make sure that your machine is configured to respond to the hostname web.hoodoowebdesign.co.uk, and ensure that hostname is correctly configured in DNS. Obviously the hostname is something different at the moment, so mail coming from you ends up coming from kickseed.vpstest.local.

share|improve this answer
    
I have already changed the hosts and hostname file and setup a reverse dns on the ip for the server. Where else could this kickseed be being set? –  cosmicsafari Feb 14 '13 at 12:19
    
Probably in your web serving program, apache maybe? Spend the time to generate proper email headers in your mail script/form or make sure you're sending the right parameters to your local sendmail.. –  NickW Feb 14 '13 at 12:20
    
OK well i tracked it down to /etc/mailname file and changed it to web.hoodoowebdesign.co.uk but its giving me the same error except <www-data@kickseed.vpstest.local> is replaced with <www-data@web.hoodoowebdesign.co.uk> –  cosmicsafari Feb 14 '13 at 12:51
    
dig web.hoodoowebdesign.co.uk ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.5 <<>> web.hoodoowebdesign.co.uk ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 32941 ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;web.hoodoowebdesign.co.uk. IN A ;; Query time: 1744 msec ;; SERVER: 192.168.101.10#53(192.168.101.10) ;; WHEN: Thu Feb 14 13:10:39 2013 ;; MSG SIZE rcvd: 43 –  NickW Feb 14 '13 at 13:11
    
See that? You return no A record, you return no MX record, PLEASE go check your DNS. Unless it's a fake domain, which in that case, put the actual domain you're using.. –  NickW Feb 14 '13 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.