Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to access the report manager, which in my case is located at http://localhost/Reports. When I try to go there I get the following error:

User 'ComputerName\UserName' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

It seems that all the information I can find pertaining to this error has to do with trying to access the Report Server Web Service URL (which of course gives me the same error), and the solution to that problem requires access to the Report Manager so that's not very helpful. Also I've tried running my browser as an administrator as suggested by one solution but it didn't make any difference.

I am using Windows 8 and there is no domain. I am logged in as the same user that was used to install the operating system as well as all other software and it has sysadmin rights on the SQL Server Database Engine. Let me know what else you need to know and I'll post it asap.

share|improve this question
add comment

2 Answers

Here's how I solved this:

1) Turned on 'the' administrator account via command line:

net user administrator /active:yes

2) Logged in as the built in admin and opened the browser as an administrator

3) Successfully went to http://localhost/reports and assigned my regular admin account all the rights it needed.

I'm not sure what the difference is between the built in administrator account and my account which is an administrator. I noticed that when I selected 'Run As Administrator' to open the browser it didn't give me the normal message box to confirm, which makes me wonder whether I could have just temporarily disabled the UAC on my regular admin account and accomplished the same thing.

If anyone has any more detailed info on this please do share because I will eventually be needing to do this on many installations and would definitely like to know if there's a way I can do this without having to enable the built in admin account.

share|improve this answer
add comment

I struggled with this as well. It was impossible in Windows 8 with my own "admin" account to get the Report Server working. Worse yet I had forgotten the administrator account password I used to set up the computer.

You have to enable the administrator account in Computer Management => Local Users and Groups => Administrator; right-click, select Properties, and ensure that the "Account is disabled" check box is unchecked. Once you've done that, reboot, and at the login screen select the administrator account. If it helps, I think the password is one that has to have a capital letter and a number. It took me a few tries.

Once in the administrator account, disable UAC. To do this, open the Control Panel and type "UAC" and select the Change User Account Control option. Move the slider all the way to the bottom. You will have to reset this setting later.

Finally, configure the report server using the Reporting Services Configuration manager. I won't go into the steps here, as they are outlined elsewhere and it's a process of its own. Once you are done, click on the Report Manager link (on my machine, it's located at http://localhost:80/ReportManager --but, nevertheless, it's under the Report Manager URL tab). From there you can configure additional account access. Add your user account as an administrator, and close the window. Reset your UAC settings in the control panel. Finally, sign out of the administrator account and back into your user account.

Why this process is so complicated is beyond me. I will refrain from critical comments about any of our fellow developers or their companies.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.