Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using java on OEL 5.8 and it crashes in some applications with "Illegal memory access. [54] error". It occurs with 3 different java installations. 2 of them are Jrockit versions (R28.2.5-20-152429-1.6.0_37 and R28.2.2-7-148152-1.6.0_29), third one is Sun so i'm guessing it's not java problem, but a Linux one. Everything worked fine until few days ago when it started crashing. It doesn't crash on every java application, just few of them that are completely unrelated (both of them however have GUI).

Here is the relevant part of the dump. If needed i can upload everything.

Error Message: Illegal memory access. [54]
Signal info  : si_signo=11, si_code=2 si_addr=0x2aaaf618a000
Version      : Oracle JRockit(R) R28.2.5-20-152429-1.6.0_37-20120927-1915-linux-x86_64
OS version   : Red Hat Enterprise Linux Server release 5.8 (Tikanga)
Linux version 2.6.18-308.13.1.0.1.el5xen (mockbuild@ca-build56.us.oracle.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-52)) #1 SMP Wed Aug 22 05:17:58 EDT 2012 (x86_64)
Hypervisor   : Xen v3.4
Thread System: Linux NPTL
LibC release : 2.5-stable
Java locking : Lazy unlocking enabled (class banning) (transfer banning)
State        : JVM is running
Command Line : -Dsun.java.command=org.tp23.antinstaller.runtime.ExecInstall swing . -Dsun.java.launcher=SUN_STANDARD org.tp23.antinstaller.runtime.ExecInstall swing .

StackOverFlow: 0 StackOverFlowErrors have occured
OutOfMemory  : 0 OutOfMemoryErrors have occured
C Heap       : Good; no memory allocations have failed
GC Strategy  : Mode: throughput, with strategy: genparpar (basic strategy: genparpar)
GC Status    : OC is not running. Last finished OC was OC#0.
             : YC is not running. Last finished YC was YC#0.
YC History   : Ran 0 YCs since last OC.
Heap Holes   : 1 hole(s), at 0x41c67000 - 0x42668000
Heap         : 0x3f5fd000 - 0x43ffe000  (Size: 64 MB)
Compaction   : (no compaction area)
Allocation   : TLA-min: 2048, TLA-preferred: 65536 TLA-waste limit: 2048
NurseryList  : 0x3f5fd000 - 0x415fd000
KeepArea     : 0x40dfcfe8 - 0x415fd000
KA Markers   : [ 0x405fcff0,  0x40dfcfe8 , 0x415fd000 ]
Forbidden A  : (none)
Previous KA  : (none)
Previous FA  : (none)
CompRefs     : References are compressed, with heap base 0x0 and shift 0.

Then module where exception occured:

Loaded modules:
(* denotes the module where the exception occured)
0000000000400000-00000000004128a3  /usr/jrockit/bin/java
00007fff2ebfd000-00007fff2ebfddb7  /usr/jrockit/bin/java
0000003cc1200000-0000003cc1201f93  /lib64/libdl.so.2
0000003cc1600000-0000003cc1615b4f  /lib64/libpthread.so.0
0000003cc0600000-0000003cc074d417  /lib64/libc.so.6
0000003cc0200000-0000003cc021bbe7 */lib64/ld-linux-x86-64.so.2
00002add13145000-00002add1344cf33  /usr/jrockit/jre/lib/amd64/jrockit/libjvm.so

And part of the stacktrace:

Thread Stack Trace:
    at _dl_relocate_object+981()@0x3cc020a855
    at dl_open_worker+569()@0x3cc0210f6a
    at <unknown>(???.c)@0x13ad64f0
    -- Java stack --
    at java/lang/ClassLoader$NativeLibrary.load(Ljava/lang/String;)V(Native Method)
    at java/lang/ClassLoader.loadLibrary0(ClassLoader.java:1807)
    at java/lang/ClassLoader.loadLibrary(ClassLoader.java:1724)
    at java/lang/Runtime.loadLibrary0(Runtime.java:823)
    at java/lang/System.loadLibrary(System.java:1028)
    at sun/font/FontManager$1.run(FontManager.java:228)
...

Thank you for your help in advance.

share|improve this question
1  
Smells like a hardware problem (bad memory maybe) –  FreshPhilOfSO Feb 15 '13 at 1:52
    
It's a virtual server on Oracle Virtual Machine, no hardware problems reported. Here is something new i found out. When i run application without gui. in text mode (it supports it), then no error appears. It is only related to some class connected with gui (specifically FontManager) –  dsmoljanovic Feb 15 '13 at 17:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.