Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In these days I'm striving trying to set a proper ftp connection with my Amazon Instance, aimed for Drupal 7.

It mounts a Linux Ubuntu 12.04 LTS and it's a Micro Instance.

I tried a lot of vsftpd guides, testing several different configurations on the vftpd.conf file. Nothing seems to matter. I tried to configure an user with the documentation I've found on the official Ubuntu forum at http://ubuntuforums.org/showthread.php?t=2076620

Nothing. When I state the user and pass I've setted, Drupal refuses the connection straight away; it doesn't even seems to try it out. Filezilla attempts a connection instead, but it runs out of time and it stops sending requests; I don't think it's a matter of timeout_settings thou, I believe there might be something wrong with the ftp itself.

I believed I could have misconfigured some setting on the machine, so I tried running another instance. FTP seems not to work properly on this kind of system. I wonder if that is because of the encrypted key it needs in order to establish a connection.

I've also read quite a lot of documentation about FTP, and I believe this guide is well worthy for everyone who has just approached the server side of life, like me :)

What do you think I am not considering in my settings?

share|improve this question

1 Answer 1

I already told you. You need to open ports 20-21, and 1024-1048 in your security group. http://stackoverflow.com/questions/7052875/setting-up-ftp-on-amazon-cloud-server

share|improve this answer
    
You are right, I started working on it a second after I read your answer, which was after I posted this question :) I'm working on it, cheers :) –  John Funk Feb 15 '13 at 2:16
    
It goes quite well from ssh. It logs succesfully with the user and the pass I gave; the problem is when I try to reach the ftp with filezilla; it times out me while logging this message out "227 Entering Passive Mode (23,,,67,4,4). I put the stars because I'm well aware that this is my ip. I'm sure this is an Amazon's firewall issue, which is not letting the passive connection in, but I can't find no help and I'm quite new to servers. Keep trying out thou –  John Funk Feb 15 '13 at 3:23
    
Did you try the entirety of that tutorial, step by step? FTP on Amazon is entirely possible - although you shouldn't be using it for anything secure, as the password's transferred in the clear. –  ceejayoz Feb 15 '13 at 14:32
    
Key parts from that tutorial will be pasv_min_port=1024 pasv_max_port=1048, most likely. –  ceejayoz Feb 15 '13 at 14:33
    
Sure I followed everything, setted all the ports both on server's firewall and vsftpd.conf file. It has a problem when trying to create the directories' tree; it goes on until it says that it was impossible to read the directory's folder. I wonder if this is a permission issue, but I don't want to put all of my folders on 777. What should i try? –  John Funk Feb 15 '13 at 15:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.