Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to configure squid to require authentication.

I've got squid to work without authentication, than I

 htpasswd -c /etc/squid3/passwd foo

after this, I've replaced

http_access allow all

with

acl foo proxy_auth REQUIRED    
http_access allow foo
http_access deny all

and added

auth_param basic program /usr/lib/squid3/ncsa_auth /etc/squid3/passwd
auth_param basic credentialsttl 30 minutes
auth_param basic casesensitive on

to /etc/squid3/squid.conf.

Now, when I do service squid3 restart, I get

stop: Unknown instance:
squid3 start/running, process 12256

when I run ps aux I can't find squid amonst processes running and the server cannot be connected to.

Why isn't this working?

UPDATE

squid3 -d 10 shows:

Can't use proxy auth because no authentication schemes are fully configured.
FATAL: ERROR: Invalid ACL: acl foo proxy_auth REQUIRED
share|improve this question
    
did you check squid's log files? –  Daniel t. Feb 16 '13 at 15:04
    
where are those located? –  Arsen Zahray Feb 16 '13 at 15:16
    
not sure, but most likely in /var/log. Otherwise, run squid in debug mode squid3 -d 10 –  Daniel t. Feb 16 '13 at 15:20
    
see update..... –  Arsen Zahray Feb 16 '13 at 15:28
add comment

1 Answer

up vote 1 down vote accepted

It appears your squid authentication configuration is missing authentication helpers, such as ncsa_auth. For step by step setup you might need to follow this tutorial.

share|improve this answer
    
the problem was that I've put the auth_param lines at the end of configuration file, while they should be before the acl foo proxy_auth.... . Thanks for the help! –  Arsen Zahray Feb 16 '13 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.