Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a problem with booting a Debian Live CD via iLO3 on a HP DL580 G7:

In the moment the boot process finishes, the video on the iLO Java Console goes away and it just says 'No Video'. Apparently, the operating system is still running though.

Some more information:

  • I'm using virtual media to boot the system
  • the iLO firmware is up-to-date

Is this a known bug? Are there any workarounds?

share|improve this question
    
Have you tried booting into text mode? –  Keith Stokes Feb 16 '13 at 15:59
1  
Have you tried any other boot CDs or operating systems? –  longneck Feb 16 '13 at 15:59
    
(out of curiosity, why use a live CD on such a beefy quad-socket server?) –  ewwhite Feb 16 '13 at 16:45

3 Answers 3

Debian live might be putting the video output in an unsupported mode. You can probably specify a video mode to use in the boot screen. Another option would be to ssh to the ilo and use the textcons command for a text console.

share|improve this answer
    
I forgot that textcons replaced remcons. –  ewwhite Feb 16 '13 at 16:21
up vote 2 down vote accepted

Turns out that this is a problem between the radeonfb and vesa modules and kernel mode setting in the current 3.2.0 kernel of Debian (probably Debian Bug #660464). Disabling modesetting by specifiying nomodeset as a kernel parameter during boot solves it.

share|improve this answer

Let's assume you have an ILO3 with the Advanced license installed, which is needed to allow remote video...

  • Can you please tell us what you've tried so far?
  • At what point in the boot process do you lose video?
  • Do you see an error that says "Video Suspended"?
  • Can you try this from the .NET Integrated Remote Console (needs Windows)?

The first thing I'd do in this case is check the ILO3's firmware revision level. The current version today is 1.50.

You can also run an ILO reboot using the Information -> Diagnostics -> Reset button. That will kill your connection, but may be necessary.

enter image description here

share|improve this answer
    
(1) I didn't try a lot of things, basically just resetting the iLO, but that doesn't help. (2) somewhen late during the live-config scripts (3) yes, exactly (4) yes, we did initially discover the problem using the .NET version and I can reproduce it with the Java one. (5) Updating to 1.50 was the first thing I did (6) see (1) :) –  Michael Feb 16 '13 at 18:46
    
Try a different boot mode for the cd. Maybe VGA=791 or something, if that's still relavent. Or just use a monitor. –  ewwhite Feb 16 '13 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.