Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I stopped an ibm x series 266 server to clean it out. It has two scsi drives in raid 1, 36 gb. While I had the drives out for cleaning I started the server to get the fans running, to exhaust dust that was being stirred up.

Now when it boots, after it runs through id'ing the scsi devices it fails to boot with 'ntldr is missing'. This is windows 2003.

When it is scanning for scsi devices it seems to find the 36gb scsi array. My idea is that because it booted without the drives once (or tried to) it somehow lost it's idea of booting from the raid array. I have been into both the main bios and the scsi setup and don't see what to do to fix this. There are two scsi channels (I think they are called, I'm not good with scsi) listed, A and B.

AIC-7902 A at slot 00 03:03:00 AIC-7902 B at slot 00 03:03:01

A only hosts the adapter on ID 7. The other channel B shows two 36gb IBM devices, those would be the hard disks, on ID 0 and 1, the adapter on 7. Both A and B have master scsi controller and boot scsi controller set to B.

Or is it finding the boot device? I don't see an OS not found message, or whatever the equivalent is for windows 2003.

Can someone point me to a config setting that would solve this issue?

share|improve this question
    
Now I've booted from a floppy. The c drive is the cd, and there is no other drive other than a:. In the bios too, the system info page shows c as the cd and no hdd. I don't get it - why are these disks not recognized? If the scsi config shows a 36gb device, that almost has to be the hdd? So why can't it be found at boot time? –  meridian Feb 17 '13 at 17:10
    
Also, in the ibm bios in the startup option area, under pci device boot priority, it says Planar scsi. As far as I can tell that ought to be the directive to boot from scsi. –  meridian Feb 17 '13 at 17:29
    
Also, if I pull the two disks out, at the next boot it says configuration changed, and likewise when I put them back in. –  meridian Feb 17 '13 at 17:42

1 Answer 1

So, it's solved.

In the main bios, in startup options, pci device boot priority was set to Planar SCSI. I set it to Slot1, and rebooted. I then set it back to Planar SCSI, and at the next reboot it found the hdd and windows 2003 started normally. Whew!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.