Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're doing a "try-out" of SmarterTools SmarterTrack (help desk) software. We can't get it to send email. We showed someone at SmarterTools our log - SmarterTrack keeps its own SMTP log - and they said it's because we're using IPv6, which SmarterTrack doesn't support.

This is a web server. We have several websites that send email through Classic ASP or PHP apps. (Our company email is handled elsewhere.) We run SQL Server 2008 R2 and My SQL, SQL Back-up Pro, and currently, that's about it. The server is accessed through Remote Desktop.

I found a Microsoft "Fix it" patch to turn off IPv6 entirely, but I'm not sure of the repercussions of that.

Is there a way to force ONLY SMTP to use IPv4?

Or barring that, will I break anything by disabling IPv6 entirely?

The "Fix It" that we're looking at is at http://support.microsoft.com/kb/929852

ETA - An example of the SMTP log from SmarterTrack:

20:36:49 Connecting to fe80::a4ff:551:c90a:e8b8%11:25
20:36:49 Connection to fe80::a4ff:551:c90a:e8b8%11 failed
20:36:49 Ending delivery of C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\df7cf54a2191485582b7f24167f32644.eml
20:50:40 Queuing C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\93634452198f401897d6e76ad01eb0d5.eml for delivery
20:50:40 Starting C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\93634452198f401897d6e76ad01eb0d5.eml delivery
20:50:40 Starting delivery of C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\93634452198f401897d6e76ad01eb0d5.eml
20:50:40 Connecting to fe80::a4ff:551:c90a:e8b8%11:25
20:50:40 Connection to fe80::a4ff:551:c90a:e8b8%11 failed
20:50:40 Ending delivery of C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\93634452198f401897d6e76ad01eb0d5.eml
20:52:32 Queuing C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\13a244d8a3a54cd78e8fb4c9f7dbe965.eml for delivery
20:52:32 Starting C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\13a244d8a3a54cd78e8fb4c9f7dbe965.eml delivery
20:52:32 Starting delivery of C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\13a244d8a3a54cd78e8fb4c9f7dbe965.eml
20:52:32 Connecting to fe80::a4ff:551:c90a:e8b8%11:25
20:52:32 Connection to fe80::a4ff:551:c90a:e8b8%11 failed
20:52:32 Ending delivery of C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\13a244d8a3a54cd78e8fb4c9f7dbe965.eml
21:11:47 Queuing C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\1132e874f101459eac3a8820811028d9.eml for delivery
21:11:47 Starting C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\1132e874f101459eac3a8820811028d9.eml delivery
21:11:47 Starting delivery of C:\Program Files (x86)\SmarterTools\SmarterTrack\MRS\App_Data\Spool\Out\1132e874f101459eac3a8820811028d9.eml
share|improve this question
1  
What does the SmarterTrack logs show? I would think that if there software doesn't support sending over IPv6 then it would just send over IPv4 –  Epaphus Feb 17 '13 at 19:38
    
@Michael - SmarterTools says that IPv6 is the problem, after seeing the log. –  Julie Feb 17 '13 at 19:57
    
@Epaphus - I'll add an example to my post. I would have thought it would default to IPv4 as well. –  Julie Feb 17 '13 at 19:58
2  
I would reject the software just based on that ridiculous claim from the vendor. If they can't make it work right in a dual stack environment, they have no business being in business. Anyway, their log says nothing about why the connection failed, which is pretty stupid. I'd check to make sure that that is the right address for the SMTP server, and that it's listening on IPv6. Turning off IPv6 is very high risk, since you will have to deploy it on your network within the expected lifecycle of this software. –  Michael Hampton Feb 17 '13 at 20:05
    
The SMTP server address is correct. How do I see if it's listening on IPv6? (If you check my profile, you'll see I list myself as a Server Idiot) We're looking at this software because we can purchase it outright for $1300. The other options that will do what we need are SaaS, and run $5000 to $10000 per year. We really want to make this work. –  Julie Feb 17 '13 at 20:14

1 Answer 1

I have had a look at the SmarterTrack documentation and it looks like it doesn't come with it's own SMTP server for sending mail.

As SmarterTrack does not utilize an internal SMTP server to send emails messages, Administrators will use this section to specify the email settings SmarterTrack will use to send messages and error notifications from the system.

At a guess it looks like the server is not running an SMTP server or the SMTP server is not listening on IPv6.

If the host server is not running an SMTP server you have a few options.

  1. Use a existing SMTP server if you have one (Exchange, Exim, Sendmail, etc)
  2. Use a smarthost
  3. Install an SMTP server on the host

If the server already has an SMTP server installed then to see if the SMTP server is listening use the following commands in a command prompt

IPv4: netstat -a -p tcp
IPv6: netstat -a -p tcpv6

You should see something like this for IPv4

Proto  Local Address          Foreign Address        State
TCP    0.0.0.0:25             Server:0                 LISTENING

or for IPv6

Proto  Local Address          Foreign Address        State
TCP    [::]:25                Server:0                 LISTENING

If you only see it listening on IPv4 then if you set the mail server address in the SmarterTrack setting use the IPv4 address of the server it should only try and talk over IPv4.

If it is listening then you can test it using telnet by doing the following

Open up a command prompt and put in the following

telnet <serverip> 25

Then enter these at one line at a time after the server has responed

EHLO domain.com
MAIL FROM:<From email address set in SmarterTrack>
RCPT TO:<your email address>
DATA
Hello this is a test.
.

If all goes well you should get an email and something like this

220 mx.domain.com Microsoft ESMTP MAIL Service ready at Sun, 17 Feb 2013 23:00:4                                              8 +0000
EHLO domain.com
250-mx.domain.com Hello 
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH NTLM
250-8BITMIME
250-BINARYMIME
250 CHUNKING
MAIL FROM: SmarterTrack@domain.com
250 2.1.0 Sender OK
RCPT TO: me@domain.com
250 2.1.5 Recipient OK
DATA
354 Start mail input; end with <CRLF>.<CRLF>
Hello this is a test.
.
250 2.6.0 <d682f7c3-415a-4b32-a843-9b422dce9e26@mx.domain.com> [InternalId=920276] Queued mail for delivery

If it fails then post the output and I should be able to point you in the right direction

share|improve this answer
    
That was interesting. Worked fine, not a hitch, but still no mail from SmarterTrack. I looked at our SMTP logs (OUR logs, not the ones in SmarterTrack) and noticed that all of the classic ASP apps/websites use the Google IP address (we run company email through Google), and the PHP apps use the SMTP address on our server. So I tried subbing the Google IP address into SmarterTrack, and it didn't work either. But it makes me wonder if I don't have some odd DNS problem. –  Julie Feb 18 '13 at 0:06
    
I assume you are using the SMTP server which comes with IIS? If so then it doesn't look that supports IPv6, however giving SmarterTrack the IPv4 address of the server should mean that it shouldn't try IPv6 and would work, Maybe you could try setting the mail server in SmarterTrack to be 127.0.0.1 which the IPv4 loopback address. When you used Google's IP was did you get the same error in the SMTP logs or was it a different error? –  Epaphus Feb 20 '13 at 0:17
    
Yes, I'm using the SMTP that comes with IIS. I tried localhost, but haven't tried 127...etc. I'll do that. (I did try the actual IPv4 address of the mail server, but that didn't help.) Unfortunately, the errors in the SmarterTrack SMTP log leave something to be desired. Whenever it fails, all it says is "failed". I wish they'd just run them through the regular channels! Our Google server had the same error. I'm wondering, though, if I couldn't use a smarthost address through a Google address. I have a note into their tech support; no answers yet. –  Julie Feb 20 '13 at 4:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.