Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use php_fpm_event on my server and after 30 seconds of execution the process is being killed and I see Internal Server Error.

However I've set much larger values:

[admin]
listen = 127.0.0.1:57797
listen.backlog = -1
listen.allowed_clients = 127.0.0.1
user = admin
group = admin
pm = dynamic
pm.max_children = 30
pm.start_servers = 2
pm.min_spare_servers = 2
pm.max_spare_servers = 6
pm.max_requests = 1000
;pm.status_path = /status
;ping.path = /ping
;ping.response = pong
request_terminate_timeout = 300s
request_slowlog_timeout = 300s
slowlog = /var/log/php-fpm/slow.log
rlimit_files = 1024
rlimit_core = 0
;chroot =
;chdir = /var/www
catch_workers_output = yes
security.limit_extensions = .php .php3 .php4 .php5

env[HOSTNAME] = $HOSTNAME
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp

;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f webmaster@domain.com
;php_flag[display_errors] = off
php_admin_value[error_log] = /var/log/php-fpm/error.log
php_admin_value[session.save_path] = /var/lib/php/session
php_admin_flag[log_errors] = on
php_admin_value[memory_limit] = 256M

Phpinfo confirms that execution_time is 300 seconds. So why does this happen ?

After 5 minutes of time I got such logs:

[17-Feb-2013 22:35:36] WARNING: [pool admin] child 7308, script '/home/admin/nowosci.org/td/odpal.php' (request: "GET /td/odpal.php") executing too slow (306.607536 sec), logging
[17-Feb-2013 22:35:44] WARNING: [pool admin] child 7308, script '/home/admin/nowosci.org/td/odpal.php' (request: "GET /td/odpal.php") execution timed out (313.981994 sec), terminating
[17-Feb-2013 22:35:44] WARNING: [pool admin] child 7308 exited on signal 15 (SIGTERM) after 679.176797 seconds from start

Why it shows Internal Server Error after just 30 seconds ?

share|improve this question
1  
And your max_execution_time is ... ? –  Karma Fusebox Feb 17 '13 at 21:37
    
It was reporting 300s –  Spacedust Feb 18 '13 at 16:22
add comment

1 Answer

up vote 0 down vote accepted

I found an answer:

 FastCGIExternalServer "/home/admin/nowosci.org/nowosci.org.0fake" -host 127.0.0.1:57797

while there should be

FastCGIExternalServer "/home/admin/nowosci.org/nowosci.org.0fake" -host 127.0.0.1:57797 -idle-timeout 300
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.