Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just got a new VPS and everything is working fine except one little detail: DNS. Frankly I have very limited (non-existent) experience with BIND (or DNS in general) and after quite a long time I'm now losing my will to live.

My domain is bartplatak.net and VPS residents on 212.1.209.239. I have pointed my domain's DNS record to my DNS server (seems to work alright), configured and started my named. However, DNS lookup says that the connection was 'refused'. DNS Crawler just outputs:

Querying a.root-servers.net (198.41.0.4)... delegated
  Querying k.gtld-servers.net (192.52.178.30)... delegated
    Querying ns2.bartplatak.net (212.1.209.239)... refused
    Querying ns1.bartplatak.net (212.1.209.239)... refused
Unable to find: bartplatak.net

My /etc/named.conf:

options {
    //listen-on port 53 { 127.0.0.1; };
    //listen-on-v6 port 53 { ::1; };
    directory   "/var/named";
    dump-file   "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
    allow-query     { localhost; };
    recursion yes;
    version "Nope.";
    dnssec-enable yes;
    dnssec-validation yes;
    dnssec-lookaside auto;

    /* Path to ISC DLV key */
    bindkeys-file "/etc/named.iscdlv.key";

    managed-keys-directory "/var/named/dynamic";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
    type hint;
    file "named.ca";
};

zone "bartplatak.net" IN{
    type master;
    file "bartplatak.net";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";

And /var/named/bartplatak.net

$TTL    86400;

@ IN SOA ns2.bartplatak.net. admin.bartplatak.net. (
    2010062801  ; Serial
    10800       ; Refresh
    3600        ; Retry
    6040800     ; Expire
    86400       ; Minimum
)

bartplatak.net.     IN NS   ns1.bartplatak.net.
bartplatak.net.     IN NS   ns2.bartplatak.net.

bartplatak.net.     IN A    212.1.209.239
ns1.bartplatak.net. IN A    212.1.209.239
ns2.bartplatak.net. IN A    212.1.209.239
test.bartplatak.net.    IN A    212.1.209.239

Any idea on what is going on?

share|improve this question
    
Pay Amazon $0.50/month to handle this for you with Route53, or any of the many other paid (and some good free) DNS providers. You've already spent the first decade's worth of their fees in your own time trying to resolve this. –  ceejayoz Feb 17 '13 at 21:48

1 Answer 1

up vote 1 down vote accepted

Well, you restrict queries to localhost:

    allow-query     { localhost; };

Also reconsider if recursive yes; is really necessary for your server.

share|improve this answer
    
Well now I feel plain stupid :L Thanks a lot, work perfectly now. –  Bart Platak Feb 17 '13 at 22:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.