Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After installing Exchange 2010 SP2 the The Microsoft Exchange RPC service can't be started. All other services are working, including ActiveSync & OWA.

In the application log this is noted: The Microsoft Exchange RPC service can't be started because the EMSMDB interface is already registered by another process.

Before the update this was working fine, no other changes were made.

One other event in the system log: The WinRM service failed to create the following SPNs: WSMAN/MYSERVER.mydomain.local; WSMAN/MYSERVER.

Additional Data The error received was 8344: %%8344.

User Action The SPNs can be created by an administrator using setspn.exe utility.

I don't know if this is related.

I've searched about the event logged in the application log, but none seems the be related to my situation.

Exchange 2010 is running on Windows 2008 R2 server. The server is also an active directory domain controller.

Thanks in advance,

** Update ** So far still no running ExchangeRPC service. The only way I can work with exchange is by OWA and ActiveSync. Is it an idea to run SP3 again?

Marcel

share|improve this question
    
Well, do the SPN's exist, and if not did you try to create them manually as specified in User Action? You can use AD Users and Computers to inspect the servicePrincipalName attribute for the principal (the server) that requires that name or setspn.exe -l. –  Greg Askew Feb 18 '13 at 12:43
    
I will try it, do you think it's related? –  MarcelDevG Feb 18 '13 at 13:00
    
the SPN's exist now, the error in the system event log is gone. I've rebooted, but the Microsoft Exchange RPC service still does not start with the same error : The Microsoft Exchange RPC service can't be started because the EMSMDB interface is already registered by another process. –  MarcelDevG Feb 18 '13 at 22:06

3 Answers 3

up vote 1 down vote accepted

I've been struggling with a similar issue myself, and I believe I've finally found a solution:

Set the Microsoft Exchange Information Store service to Automatic(Delayed Start)

** This may break Outlook Anywhere Access **

Even though it's not documented anywhere, the RPC Client Access Service requires port 6001, and the Exchange Information Store service is configured to register port 6001 for RPC over HTTP, used by Outlook Anywhere clients. This setting is configured in in a REG_DWORD named "Rpc/HTTP Port" located in HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParameterSystem. So, if the Exchange Information Store service starts before the Exchange RPC Client Access service starts then the Information Store service registers port 6001. This results in the RPC service being unable to register that port, which is what it's sort of telling you in that error message.

It's possible that changing the value of the Rpc/HTTP registry value might also fix the problem, but the only Microsoft KB I could find that talked about this registry value strongly discouraged changing it. Granted, this was for Exchange Server 4, 4.5, and 5. However, it's not necessary to change this value just to get the RPC Client Access Service working again.

How I figured this out: I'm running Exchange 2010 SP3 on Windows Server 2012, and have been having issues with the RPC Client Access service failing to start. In my situation, sometimes the service would start after a reboot, and sometimes it wouldn't. If it didn't start automatically then manually starting it always failed, with the error "The Microsoft Exchange RPC service can't be started because the EMSMDB interface is already registered by another process". The only solution I found was to restart the server again, and hope that the RPC Client Access Service started. configuring static ports for RPC and the Address book didn't help. Nor did setting the RPC Locator Service to Auto. I first saw a reference to port 6001 in this ExpertsExchange thread (I was desperate!). I also saw it mentioned on this TechNet support thread. In my case, I noticed netstat was reporting port 6001 was being used by store.exe. Stopping the Information Store service allowed me to start the RPC Client Access service. I then started the Information Store service again. The Information Store service started successfully, but did log an error in the Application error log:

Event 9691, MSExchangeIS

Status 0x000006CC registering RPC protocol "ncacn_http" endpoint="6001". This may be expected, depending on the machine configuration.

Details:

- System 
  - Provider 
   [ Name]  MSExchangeIS 
  - EventID 9691 
   [ Qualifiers]  49158 
   Level 2 
   Task 6 
   Keywords 0x80000000000000 
  - TimeCreated 
   [ SystemTime]  2013-04-18T18:52:52.000000000Z 
   EventRecordID 60555 
   Channel Application 
   Computer DT-Mailserver.diamondtitleco.com 
   Security 
- EventData 
   0x000006CC 
   ncacn_http 
   6001    5B444941475F4354585D00003E000000FF8C0E0000000000000230000000CD4A201000000000BD5F201000000000BD5F201000000000CD4A201000000000FD79201000000000FD79201000000000 

Hopefully this will be of some use to someone!

share|improve this answer
    
Thanks a million, I almost reinstalled the complete server! Too bad the bounty did expire. The strange thing is, before SP3 i've never encountered this problem and Outlook Access Anywhere was also working (but not anymore). –  MarcelDevG Apr 23 '13 at 13:15

There are a couple of things to check...

1) First thing first, it should have created an installation log? (path for the log files is usually the root of the installation drive for example: C:\ExchangeSetupLogs\ExchangeSetup.txt)

2) If you have custom ports for MSExchangeRPC, check firewall ports are open. Check the port itself under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeRPC\ParametersSystem\TCP/IP Port

3) Set the Remote Procedure Call (RPC) Locator automatic, restart server, try and start Microsoft Exchange RPC Service

share|improve this answer
    
1) OK, where should the log be? 2) NO There is no custom port, the reg is ParametersSystem does not exists. This was also the case before the update. 3) I tried this with no luck. –  MarcelDevG Feb 18 '13 at 10:10
    
Found log files in \ExchangeSetupLogs ExchangeSetup.log has 57.000+ lines, so not sure where to look... –  MarcelDevG Feb 18 '13 at 10:32
    
These logs includes past installations as well, scroll all the way down, look for keywords such as 'error', 'abort', 'cancelled' –  Cold T Feb 18 '13 at 10:37
    
ok, that's only 20.000+ lines. There are a lot of references with error or fail... i will look into it.... But are we on the right track? what means "EMSMDB interface is already registered by another process"? –  MarcelDevG Feb 18 '13 at 11:14

Please have a look at this thread from microsoft forums,

http://social.technet.microsoft.com/Forums/zh/exchange2010/thread/981dbec3-8b6d-486b-9040-6292aec45905

and HP forums

http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&dlc=en&docname=c03215402

The user may try the steps given below:

Change the Remote Procedure Call (RPC) Locator to "Automatic".
Restart the server.
Then start the Microsoft Exchange RPC Service .
or
Stop all Microsoft Exchange Services .
Change the Remote Procedure Call (RPC) Locator to "Automatic".
Now start all the Microsoft Exchange Services including Microsoft Exchange RPC .
share|improve this answer
    
I have tried that (as Cold T suggested at point 3), but it didn't help.... –  MarcelDevG Feb 28 '13 at 15:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.