Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

LSPCI does show the cards have been recognised by the system but I really don't know what to do to check the cards functionality. How can I setup a test network or something else to verify the cards aren't broken?

It would be really helpfull if someone has an idea because we have a customer who is still interessted to buy these cards.

I'm working with a Fedora 17 x86 with a 3.4.9-1 Kernel on a HP xw4100 workstation but other machines are available too.

share|improve this question
    
More detail is needed! OS distribution, kernel, hardware type, etc. –  ewwhite Feb 18 '13 at 10:55
    
This is all I know. These are HIPPI network cards and I've to check if they are broken or still useable. –  Kaai Kivi Feb 18 '13 at 11:03

1 Answer 1

up vote 2 down vote accepted

You could just:

  1. connect them to another network card in the same machine with some network cable,
  2. then ifconfig up them both while making sure they are in the same network (use a different IP that belongs to the same network as specified by the netmask, e.g. 192.168.0.1/24 and 192.168.0.2/24).
  3. then check route -n and make sure traffic for that network is routed correctly.
  4. then you can ping -I from one interface to another and check if the card is working.

To do some stress test, you could try ping -f.

share|improve this answer
    
I tried but ifconfig -a doesn't know about the cards –  Kaai Kivi Feb 18 '13 at 11:43
    
@KaaiKivi do you have the kernel modules for the card? IOW, what is the output of zcat /proc/config.gz | grep CONFIG_HIPPI? –  Attila O. Feb 18 '13 at 11:45
    
"No such file or directory" –  Kaai Kivi Feb 18 '13 at 11:48
    
@KaaiKivi oh right, you probably don't have the runtime config support in your kernel. Can you modprobe hippi? If not, it is either compiled in into your kernel, or not present at all. Maybe try compiling a kernel with CONFIG_HIPPI enabled. See cateee.net/lkddb/web-lkddb/HIPPI.html for details. –  Attila O. Feb 18 '13 at 11:51
    
It seems the HIPPI support is missing. I'll try to compile a kernel later. Thanks a lot! –  Kaai Kivi Feb 18 '13 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.