Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a very strange problem with my ethernet card. Here is ethernet card details:

description: Ethernet interface
   product: RTL8169 PCI Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 1
   bus info: pci@0000:03:01.0
   logical name: eth0
   version: 10
   serial: 00:e0:52:fb:64:09
   size: 100MB/s
   capacity: 1GB/s
   width: 32 bits
   clock: 66MHz
   capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=88.200.101.157 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100MB/s
   resources: irq:18 ioport:e000(size=256) memory:f7d20000-f7d200ff memory:f7d00000-              f7d1ffff

I bought this NIC and when i use it after a little while internet speed drops from 100Mb/s to less than 10Mb/s. Reason for that is very strange ping (ping drops from 100ms to 1ms with 1ms intervals and when it comes to 1ms it goes to 100ms again and same happen). I cant figure out what is causing that ping, but im sure it is software problem, because ping cant drop in 1ms intervals so even. So any driver suggestions or something. Here is my pic of ping.

One more thing: If I unplug and plug the nic (when internet speed drops) it works for a while with full speed and then (after couple hours) it drops again.

share|improve this question
    
what version of Linux are you running? Have you looked in any logs for errors? –  Sc0rian Feb 18 '13 at 13:13
    
Anything reported in /var/log/messages? What you show seems to indicate the card negotiated 100Mbps, whas it "halfway slow" then? Have you tried another port on the switch? –  vonbrand Feb 18 '13 at 13:13
    
Have you tried with another machine? Is it possible that the net cable goes near an interference source (fluorescent light, ...)? –  vonbrand Feb 18 '13 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.