Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm unable to get my qmailtoaster working on CentOS 5.9 64-bit:

[root@nowosci supervise]# qmailctl stat
authlib: up (pid 2653) 212 seconds
clamd: up (pid 2658) 212 seconds
imap4: up (pid 2663) 212 seconds
imap4-ssl: up (pid 2652) 212 seconds
pop3: up (pid 2667) 212 seconds
pop3-ssl: up (pid 2659) 212 seconds
send: up (pid 13957) 0 seconds
smtp: up (pid 2665) 212 seconds
spamd: up (pid 2655) 212 seconds
submission: up (pid 2643) 212 seconds
authlib/log: up (pid 2656) 212 seconds
clamd/log: up (pid 2666) 212 seconds
imap4/log: up (pid 2664) 212 seconds
imap4-ssl/log: up (pid 2654) 212 seconds
pop3/log: up (pid 2660) 212 seconds
pop3-ssl/log: up (pid 2657) 212 seconds
send/log: up (pid 2644) 212 seconds
smtp/log: up (pid 2661) 212 seconds
spamd/log: up (pid 2650) 212 seconds
submission/log: up (pid 2662) 212 seconds

Send is down. When running manually I got:

[root@nowosci send]# ./run
alert: cannot start: unable to switch to queue directory

Is there anything wrong here:

    [root@nowosci /]# ls -l /var/qmail/
razem 48K
drwxr-sr-x  2 alias  qmail 4,0K sty 22 17:26 alias
drwxr-xr-x  2 root   qmail 4,0K lut 18 23:57 bin
drwxr-xr-x  2 root   qmail 4,0K lut 18 23:56 boot
drwxr-xr-x  4 root   qmail 4,0K lut 18 23:57 control
drwxr-xr-x  2 root   qmail 4,0K lut 18 23:56 doc
drwxr-xr-x 10 root   qmail 4,0K lut 18 23:56 man
drwxr-xr-- 12 qmailq qmail 4,0K lut 18 23:56 queue
-rwxr-xr-x  1 root   qmail  215 sty 22 17:26 rc
drwxr-x---  3 clamav root  4,0K sty 22 17:28 simscan
drwxr-xr-x  3    201 qmail 4,0K lut  3 21:58 spamdyke
drwxr-xr-x 12 qmaill qmail 4,0K lut 18 23:57 supervise
drwxr-xr-x  2 root   qmail 4,0K lut 18 23:56 users

or here ?

    [root@nowosci /]# ls -l /var/qmail/queue/
razem 40K
drwxr--r--  2 qmails qmail 4,0K sty 22 17:26 bounce
drwxr--r-- 25 qmails qmail 4,0K lut 18 23:56 info
drwxr--r--  2 qmailq qmail 4,0K lut 19 00:16 intd
drwxr--r-- 25 qmails qmail 4,0K lut 18 23:56 local
drwxr-xr--  2 qmailq qmail 4,0K lut 18 23:56 lock
drwxr-xr-- 25 qmailq qmail 4,0K lut 18 23:56 mess
drwxr--r--  2 qmailq qmail 4,0K lut 19 00:16 pid
drwxr--r-- 25 qmails qmail 4,0K lut 18 23:56 remote
drwxr-xr--  2 qmailq qmail 4,0K lut 19 00:16 todo
drwxr-xr-x  2 root   root  4,0K sty 28 15:19 yanked
share|improve this question

1 Answer 1

up vote 0 down vote accepted

Solution was simple, remove all qmail packages then remove old users and groups:

deluser qmaillog
delgroup qmail

Then reinstall qmail packages and all is working ok ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.