Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I try and try and try to performance and fix problem with gluster, i try all. I served on gluster webpages, php files, images etc. I have problem after update from 3.3.0 to 3.3.1. I try 3.4 when i think maybe fix it but still the same problem. I temporarily have 1 brick, but before upgrade will be fine.

Config:
Volume Name: ...
Type: Replicate
Volume ID: ...
Status: Started
Number of Bricks: 0 x 2 = 1
Transport-type: tcp
Bricks:
Brick1: ...:/...
Options Reconfigured:
cluster.stripe-block-size: 128KB
performance.cache-max-file-size: 100MB
performance.flush-behind: on
performance.io-thread-count: 16
performance.cache-size: 256MB
auth.allow: ...
performance.cache-refresh-timeout: 5
performance.write-behind-window-size: 1024MB

I use fuse, hmm "Maybe the high load is due to the unavailable brick" i think about it, but i cant find information on how to safely change type of volume. Maybe u know how?

share|improve this question
add comment

1 Answer

You could try downgrading to 3.2 or 3.3.0?

I've had high iowait problems when I tried using nfs. Are you using the fuse mount or nfs? Why is the number of bricks 0 x 2? Maybe the high load is due to the unavailable brick?

My options are like this and are working fine for mail storage (many small files):

Volume Name: shrdata
Type: Replicate
Volume ID: 1e3ea45e-3d84-49c7-a647-ef92398cc433
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: srv1:/storage
Brick2: srv2:/storage
Options Reconfigured:
performance.quick-read: off
performance.io-cache: off
performance.io-thread-count: 16
network.frame-timeout: 45
cluster.self-heal-window-size: 128
performance.write-behind-window-size: 4MB
performance.flush-behind: off
performance.cache-size: 128MB
cluster.data-self-heal-algorithm: diff
performance.cache-refresh-timeout: 30
performance.stat-prefetch: off
nfs.disable: off
network.ping-timeout: 10
performance.read-ahead: on
cluster.self-heal-daemon: on
nfs.export-dir: /storage
nfs.export-volumes: on
share|improve this answer
    
I use fuse, hmm "Maybe the high load is due to the unavailable brick" i think about it, but i cant find information how safe change type of volume. Meady u know how? –  Sara Feb 19 '13 at 20:00
    
Hmmm, after change to distribute still the CPU very high load ;( any ideas? –  Sara Feb 20 '13 at 1:38
    
I remember one think, i update OS (Centos) before update Gluster, i try version 3.3.0 3.3.1 3.4.0 and change to distributed, still CPU very load ;( –  Sara Feb 20 '13 at 3:28
    
I think maybe something on client by fuse will wrong because client command high cpu usage, any ideas? –  Sara Feb 20 '13 at 7:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.