Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've just moved from old to new server but have many problems now. What I did was:

  1. Initial set up of cpanel; 2. Change of hostname from default to my domain aaa.aaa.com; 3. Migrate multiple accounts via cpanel VHM; 4. Changed one site's DNS to new server.

Now on this site I have frequent and random 500 errors, sometimes "out of memory" errors and many more problems which I havent had anything like it before.

I'm particularly interested in this: when the wordpress site on a new server was live, I realised that there are 500 errors and I closed it with "underconstruction" wp plugin and did some other changed in WP backend, but it seems that all those changes were applied to my old site.

How can it be if it was on a new server, with different ip and new dns? If I change something on a new, the old one changes.. Are they in sync? Could those 500 errors be because of those two servers in conflict or smth?

share|improve this question

closed as not a real question by Michael Hampton, Dave M, mdpc, Khaled, mgorven Feb 19 '13 at 18:39

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

    
The body of your question seems to be asking different things to the title of your question. –  nickgrim Feb 19 '13 at 13:59

1 Answer 1

up vote 0 down vote accepted

Out of memory is because the php.ini memory_limit setting. Here's what you can do:

  1. Increase php.ini memory_limit:
    Create a file php.ini in the directory where your WordPress is and add the following line
    memory_limit = 64M
  2. Changing the Memory Limit via wp-config.php In wp-config.php add the following line define('WP_MEMORY_LIMIT', '64M');
  3. Increase memory limit via .htaccess Add to .htaccess the following line php_value memory_limit 64M

Please note that changing the value of memory_limit might be disabled by your hosting provider. If none of the above solutions work, you should contact your hosting provider.


About the 500 errors you might find some more details on error.log. Please check that.

share|improve this answer
    
Ok, fixed it. It was DNS problem.. data was being loaded from both servers. That is, had to wait for DNS propagation to finish. Regarding "out of memory errors", the php limit was set to 32mb which is really low, so increasing that figure got rid of various errors. –  Dxr Tw Feb 21 '13 at 15:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.