Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a problem with Time-To-Reach-Queue being too long in Microsoft Message Queuing on some servers running Windows Server 2008 R2 .

How can we change the default time on the servers from 4 days to a lower value?

(Copy of: http://stackoverflow.com/questions/14957867/how-to-change-default-msmq-time-to-reach-queue-time)

share|improve this question

1 Answer 1

If you are talking about servers that belong to a domain AND have MSMQ installed in AD-integrated mode, a default setting for "MaxTimeToReachQueue" can be changed in the "sites and services" MMC snapin. Expand the services folder, right click the "msmqServices" object and set the value on the "general" tab.

Set the default lifetime for messages

Any workgroup-mode installations of MSMQ need to specify the value in the code when sending a message.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.