Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Since upgrading to Jenkins 1.502, any jobs using git on remote UNIX slaves launched by SSH fail with

hudson.util.IOException2: remote file operation failed: /var/ciworkspaces/web/workspace/DFT.BA Live at hudson.remoting.Channel@14930f2a:web-pampas
    at hudson.FilePath.act(FilePath.java:861)
    at hudson.FilePath.act(FilePath.java:838)
    at hudson.plugins.git.GitSCM.determineRevisionToBuild(GitSCM.java:956)
    at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1123)
    at hudson.model.AbstractProject.checkout(AbstractProject.java:1342)
    at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:683)
    at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
    at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:588)
    at hudson.model.Run.execute(Run.java:1568)
    at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
    at hudson.model.ResourceController.execute(ResourceController.java:88)
    at hudson.model.Executor.run(Executor.java:237)
Caused by: java.io.IOException: Unable to serialize hudson.FilePath$FileCallableWrapper@3e2c693b
    at hudson.remoting.UserRequest.serialize(UserRequest.java:166)
    at hudson.remoting.UserRequest.<init>(UserRequest.java:62)
    at hudson.remoting.Channel.call(Channel.java:671)
    at hudson.FilePath.act(FilePath.java:854)
    ... 11 more
Caused by: java.io.NotSerializableException: hudson.model.FreeStyleBuild
    at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1180)
    at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
    at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
    at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
    at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
    at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
    at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
    at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
    at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
    at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
    at hudson.remoting.UserRequest._serialize(UserRequest.java:155)
    at hudson.remoting.UserRequest.serialize(UserRequest.java:164)
    ... 14 more
Finished: FAILURE

I've found a few pages about this error (one, two) but nothing conclusive about what it is or how to fix it.

This is happening on all slaves launched with SSH or Launch slave via execution of command on the Master when using git (possibly other SCMs, not tested because we only use git). Jobs that don't have git repos attached work fine.

I have verified the file permissions, and as the user slave.jar is running as I can CD to the workspace directory, create the job directory and clone the git repo. I've tried deleting all the *.jar files copied over and re-launching the slaves but they still don't work.

This is only happening since upgrading from 1.454 to 1.502, the slaves worked correctly before with no issues.

Other maybe useful information;

[sr@pampas ~]$ cat /etc/redhat-release 
CentOS release 6.3 (Final)
[sr@pampas ~]$ java -version
java version "1.7.0_09-icedtea"
OpenJDK Runtime Environment (rhel-2.3.5.3.el6_3-x86_64)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)

This is the same on the master and slaves

share|improve this question
    
Can you paste the xml job definition if possible? –  Tom O'Connor Feb 24 '13 at 18:43
    
@TomO'Connor gist.github.com/samarudge/ad356345ee01a0880259 is an example but it happens for any remote job with a GIT repo. Running the build on 'master' works fine –  sam Feb 25 '13 at 17:03
    
Hi Sam - Did you have any luck in solving this? It's driving me insane! –  TJ Biddle Apr 13 '13 at 22:31
    
@TJBiddle Nope, just downgraded Jenkins back to 1.454 =/ –  sam Apr 16 '13 at 8:56

1 Answer 1

With jenkins being release almost every week, bugs may be released too.

You should simply rollback to an old version or just wait for the next one.

Checking their bug tracker may help finding workaround, and to help for problems being fix as early as possibile.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.