Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My EC2 instance tries to mount glusterfs volume whic located on another EC2 instance .

client instance's /etc/fstab file contains:

glusterserver1:/export/brick1 /mnt/glusterfs glusterfs defaults 0 0

when I try to mount it

mnt -a

But it gives error. The glusterfs log for my client like below:

[2013-02-19 17:49:46.757834] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.1
[2013-02-19 17:49:46.777490] E [socket.c:1715:socket_connect_finish] 0-glusterfs: connection to  failed (Connection refused)
[2013-02-19 17:49:46.777581] E [glusterfsd-mgmt.c:1787:mgmt_rpc_notify] 0-glusterfsd-mgmt: failed to connect with remote-host: Transport endpoint is not connected
[2013-02-19 17:49:46.777608] I [glusterfsd-mgmt.c:1790:mgmt_rpc_notify] 0-glusterfsd-mgmt: -1 connect attempts left
[2013-02-19 17:49:46.777847] W [glusterfsd.c:831:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_transport_notify+0x28) [0x7f604baf7018] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0xc0) [0x7f604bafb850] (-->/usr/sbin/glusterfs() [0x40c066]))) 0-: received signum (1), shutting down
[2013-02-19 17:49:46.777894] I [fuse-bridge.c:4648:fini] 0-fuse: Unmounting '/mnt/glusterfs'.
[2013-02-19 21:18:48.036389] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.1
[2013-02-19 21:19:51.210472] E [socket.c:1715:socket_connect_finish] 0-glusterfs: connection to  failed (Connection timed out)
[2013-02-19 21:19:51.210751] E [glusterfsd-mgmt.c:1787:mgmt_rpc_notify] 0-glusterfsd-mgmt: failed to connect with remote-host: Transport endpoint is not connected
[2013-02-19 21:19:51.210782] I [glusterfsd-mgmt.c:1790:mgmt_rpc_notify] 0-glusterfsd-mgmt: -1 connect attempts left
[2013-02-19 21:19:51.211347] W [glusterfsd.c:831:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_transport_notify+0x28) [0x7fde6181e018] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0xc0) [0x7fde61822850] (-->/usr/sbin/glusterfs() [0x40c066]))) 0-: received signum (1), shutting down
[2013-02-19 21:19:51.211452] I [fuse-bridge.c:4648:fini] 0-fuse: Unmounting '/mnt/glusterfs'.

Could you help me please?

share|improve this question
    
My security group allows: port 22, 11, 24007-24009 –  zontragon Feb 19 '13 at 21:36
    
Does glusterserver1 resolve? Is the Gluster server running? Can you mount the brick from the server itself? –  mgorven Feb 19 '13 at 21:47
    
glusterserver is running. ping glusterserver is not responding –  zontragon Feb 19 '13 at 21:50
    
This command "sudo gluster volume info" results => Volume Name: vdgluster_vol_0 Type: Replicate Status: Started Number of Bricks: 2 Transport-type: tcp Bricks: Brick1: glusterserver1:/export/brick1 Brick2: glusterserver2:/export/brick1 –  zontragon Feb 19 '13 at 21:52
    
Did you find a solution to this? I have the exact same problem. –  Danny Shepherd Jun 13 '13 at 14:57

1 Answer 1

  1. check the security group of server instances. Just to make sure it is not because of security group enable ALL Traffic for all the server instances.
  2. instead of fstab try to mount using mount.glusterfs server:vol mountpoint
  3. check if the volume is started ? gluster volume vol-name status | start
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.