Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm migrating my development environment to the cloud to help with working remotely, and I've just come up against a bit of a roadblock.

I have an Amazon EC2 instance running Windows 2008 R2, and I can configure the environment there to my needs. The problem is that when I try to VPN from that server to my workplace, my RDP session drops out.

This is probably logical, as the traffic to the EC2 instance is trying to go through VPN and so I can't connect directly, but I'm not sure what the answer is. I've tried connecting to the VPN from my local machine, then setting the VPN from the EC2 instance back to work, but the same thing happens.

Can this be resolved, and if so - how?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

In the VPN client properties, untick the option to "use default gateway on remote network".

To use the VPN DNS

  • enter the properties for the VPN connection
  • networking tab, and then properties for TCP/IP
  • advanced, then DNS tab

There you can include the IP addresses of DNS servers that you want to use for hosts inside the VPN.

share|improve this answer
    
That was easy, but now none of my connections go through the VPN. How do I configure some connections through the VPN and not others? –  Kirk Broadhurst Feb 20 '13 at 6:35
    
I've updated the answer to include details on adding the internal DNS server. –  Kirk Broadhurst Feb 20 '13 at 7:37
    
Thanks for the edits. Helpful and looks nice –  jkim Feb 20 '13 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.