Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Im relatively new to this so please bear with me ..

Im running an amazon instance with ubuntu 11.10

and after performing

apt-get upgrade

everything with my package manager went haywire
if i try to perform any apt-get operations i get

Fetched 35.2 MB in 7s (4,399 kB/s)                                                                                                                                
Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up apt (0.8.16~exp5ubuntu13.6) ...
ERROR: Can't find the archive-keyring
Is the ubuntu-keyring package installed?
dpkg: error processing apt (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 apt
E: Sub-process /usr/bin/dpkg returned an error code (1)

and after looking around and trying a bunch of stuff which includes :
- performing a clean and update or clean and upgrade
- taking a new sources.list altogether
- adding the keyring again
- and a whole bunch of other completely random stuff in the desperate attempt of a miracle

nothing worked ..

so any help will help me find ......no, come close a solution will be greatly appreciated :)

share|improve this question
add comment

2 Answers

The solution posted at the end of this thread worked for me: http://ubuntuforums.org/showthread.php?t=2129550

Basically find another clean ubuntu machine and copy the /usr/share/keyrings/* to ur current /usr/share/keyrings directory. I had no files in this directory when I was getting the error. Once I copied the files from another ubuntu install, apt-get started working again.

share|improve this answer
add comment

Try

 sudo apt-get clean

 sudo apt-get -f install ubuntu-keyring
share|improve this answer
    
tried .. did not work .. same thing for all apt-get operation .. –  user160870 Feb 20 '13 at 10:56
    
have you tried this help.ubuntu.com/community/EOLUpgrades –  Abhishek Anand Amralkar Feb 20 '13 at 11:01
    
There are a whole bunch of other dependencies so i would not like to perform any operations which involves something that can upset the setup seeing that i have already screwed something up :D –  user160870 Feb 20 '13 at 11:04
    
try this apt-get -f install archive-keyring –  Abhishek Anand Amralkar Feb 20 '13 at 11:34
    
nope .. still the same issue –  user160870 Feb 20 '13 at 11:47
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.