Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to open a reverse tunnel in background. When using OpenSSH ssh -NfR 9022:127.0.0.1:22 <target> always worked. When I did that with dropbear on my router, it failed like this:

# ssh -NfR 9022:127.0.0.1:22 <target>
ssh: Exited: Error resolving '9022:localhost:22' port '22'. Name or service not known

ssh -R works fine, but doesn't start in background. Leaving either 'f' or 'R' didn't help; it printed the same error. Replacing the 127.0.0.1 with localhost didn't help either.

Please, SF, help me! :)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Dropbear does not support the short form of options, try this instead:

ssh -N -f -R 9022:127.0.0.1:22 <target>
share|improve this answer
    
Damn, I should've tried that. I'll do it as soon as I have access again (about 22:00+01) –  keks Feb 20 '13 at 15:50
    
Thanks, that did it! –  keks Feb 21 '13 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.