Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've insalled the package debsecan in debian wheezy with 3.7.1 kernel. when I try to run it it gives me this output:

error: while downloading error: [Errno -2] Name or service not known

I tried this: adding repositories in /etc/apt/source.list apt-get upgrade apt-get update

But still the same result. I'd like to be able to track down what packages I have on my debian machine and which among them are vulnerable/to be removed. My goal is system minimization to harden it.

Any help ?

[EDIT] Here's the output of cat /etc/default/debsecan:

# Configuration file for debsecan.  Contents of this file should
# adhere to the KEY=VALUE shell syntax.  This file may be edited by
# debsecan's scripts, but your modifications are preserved.
# If true, enable daily reports, sent by email.

# For better reporting, specify the correct suite here, using the code
# name (that is, "sid" instead of "unstable").

# Mail address to which reports are sent.

# The URL from which vulnerability data is downloaded.  Empty for the
# built-in default.
share|improve this question

1 Answer 1

Your DNS setup is broken. Try resolving the hostname against Google's DNS servers:

% host has address mail is handled by 0

If this doesn't work then something is blocking your DNS requests.

Then try against your system's configured DNS servers:

% host has address mail is handled by 0

If this doesn't work then you've got the wrong DNS servers configured in /etc/resolv.conf.

share|improve this answer
Thank you! Turns out my DNS was indeed broken. I added the line "nameserver" in my /etc/resolv.conf and tried out debsecan again, it failed. Here's the error message: error: while downloading…: HTTP Error 404: Not Found Any idea ? – mak Feb 20 '13 at 20:57
@mak That URL downloads correctly for me. There's something very weird with your network. – mgorven Feb 20 '13 at 20:58
I can't figure out... What do you need to help me diagnose this ? – mak Feb 20 '13 at 20:59
I mean, when I click the link hereabove, it downloads in my browser loke a charm ! but debsecan seems to have trouble with it... – mak Feb 20 '13 at 21:01
@mak Do you have an HTTP proxy set anywhere? Check the $http_proxy environment variable, /etc/apt/, and debsecan configuration. – mgorven Feb 20 '13 at 21:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.