Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a linode server with a name server running on it. I have my domain: registered through GoDaddy. And the name servers set to Amazons, I am using Amazon Route 53 to manage it. I want a subdomain ( to point to my linode server that houses a name server for itself. I have already tried adding a and ns records that point to my linode ip and ns records ( and

note: I also have a reverse DNS record setup on linode with connected to MY_IP_ADDR_HERE

Amazon Record Sets for Route 53 zone record sets

From linode server in file: /var/cache/bind/

$TTL 3600       ; 1 hour         IN SOA (
                                2013021901 ; serial
                                86400      ; refresh (1 day)
                                86400      ; retry (1 day)
                                2419200    ; expire (4 weeks)
                                3600       ; minimum (1 hour)
                        A       MY_IP_ADDR_HERE
                        MX      0
mail              A       MY_IP_ADDR_HERE
ns0              A       MY_IP_ADDR_HERE
ns1              A       MY_IP_ADDR_HERE
www                     CNAME

From linode server in file /etc/bind/named.conf.default-zones (this is just the added zone

zone "" {
    type master;
    file "";

From linode name server (seems to work locally):

user@localhost:~$ dig @localhost

; <<>> DiG 9.8.1-P1 <<>> @localhost
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40844
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;   IN  A


;; AUTHORITY SECTION: 3600    IN  NS 3600    IN  NS


;; Query time: 0 msec
;; WHEN: Wed Feb 20 16:05:40 2013
;; MSG SIZE  rcvd: 128
share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need NS records in Route 53 delegating the subdomain to your Linode machine, as well as A records if the NS hostnames are in-baliwick:     NS A

There's no point in having two NS records pointing to the same IP, just use one.

share|improve this answer
That worked for adding a result to the answer section, however there is no Authority section like there is when dig is run locally, is this okay/normal? – Raymond Feb 20 '13 at 17:04
tested it using a server that updates more quickly, everything looks fine, however the NS records that show when running dig show the amazon name servers and my dont show up – Raymond Feb 20 '13 at 17:10
@Raymond You'll only get an AUTHORITY section if querying an authoritative server directly (which one doesn't usually do). Otherwise it's normal not to have it. What server are you querying? – mgorven Feb 20 '13 at 17:15
Im getting different results, when i run it \@localhost on a university server i get the authority being the amazon domains, when i query \ I get my and – Raymond Feb 20 '13 at 17:20
@Raymond The former may be due to caching, try again after the TTLs have expired. – mgorven Feb 20 '13 at 17:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.