Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a linode server with a name server running on it. I have my domain: example.com registered through GoDaddy. And the name servers set to Amazons, I am using Amazon Route 53 to manage it. I want a subdomain (ln.example.com) to point to my linode server that houses a name server for itself. I have already tried adding a and ns records that point to my linode ip and ns records (ns0.ln.example.com and ns1.ln.example.com).

note: I also have a reverse DNS record setup on linode with ln.example.com connected to MY_IP_ADDR_HERE

Amazon Record Sets for example.com: Route 53 zone record sets

From linode server in file: /var/cache/bind/ln.example.com

$ORIGIN .
$TTL 3600       ; 1 hour
ln.example.com         IN SOA  ns0.ln.example.com. hostmaster.ln.example.com. (
                                2013021901 ; serial
                                86400      ; refresh (1 day)
                                86400      ; retry (1 day)
                                2419200    ; expire (4 weeks)
                                3600       ; minimum (1 hour)
                                )
                        NS      ns0.ln.example.com.
                        NS      ns1.ln.example.com.
                        A       MY_IP_ADDR_HERE
                        MX      0 mail.ln.example.com.
$ORIGIN ln.example.com.
mail              A       MY_IP_ADDR_HERE
ns0              A       MY_IP_ADDR_HERE
ns1              A       MY_IP_ADDR_HERE
www                     CNAME   ln.example.com.

From linode server in file /etc/bind/named.conf.default-zones (this is just the added zone

zone "ln.example.com" {
    type master;
    file "ln.example.com";
};

From linode name server (seems to work locally):

user@localhost:~$ dig @localhost mail.ln.example.com

; <<>> DiG 9.8.1-P1 <<>> @localhost mail.ln.example.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40844
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;mail.ln.example.com.   IN  A

;; ANSWER SECTION:
mail.ln.example.com. 3600 IN    A   MY_IP_ADDR_HERE

;; AUTHORITY SECTION:
ln.example.com. 3600    IN  NS  ns0.ln.example.com.
ln.example.com. 3600    IN  NS  ns1.ln.example.com.

;; ADDITIONAL SECTION:
ns0.ln.example.com. 3600    IN  A   MY_IP_ADDR_HERE
ns1.ln.example.com. 3600    IN  A   MY_IP_ADDR_HERE

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Feb 20 16:05:40 2013
;; MSG SIZE  rcvd: 128
share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need NS records in Route 53 delegating the subdomain to your Linode machine, as well as A records if the NS hostnames are in-baliwick:

ln.example.com.     NS  ns0.ln.example.com.
ns0.ln.example.com. A   1.2.3.4

There's no point in having two NS records pointing to the same IP, just use one.

share|improve this answer
    
That worked for adding a result to the answer section, however there is no Authority section like there is when dig is run locally, is this okay/normal? –  Raymond Feb 20 '13 at 17:04
    
tested it using a server that updates more quickly, everything looks fine, however the NS records that show when running dig show the amazon name servers and my ns0.ln.example.com dont show up –  Raymond Feb 20 '13 at 17:10
    
@Raymond You'll only get an AUTHORITY section if querying an authoritative server directly (which one doesn't usually do). Otherwise it's normal not to have it. What server are you querying? –  mgorven Feb 20 '13 at 17:15
    
Im getting different results, when i run it \@localhost on a university server i get the authority being the amazon domains, when i query \@ns-81.awsdns-10.com I get my ns0.ln.example.com and ns1.ln.example.com –  Raymond Feb 20 '13 at 17:20
1  
@Raymond The former may be due to caching, try again after the TTLs have expired. –  mgorven Feb 20 '13 at 17:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.