Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The latest version of PCRE available in the Red Hat Enterprise Linux 6.3 repo is v7.8 and the latest version of PHP available is 5.3.3, compiled against that external PCRE v7.8 library. (PHP normally includes a newer version of PCRE, but RHEL compiles against an external library instead)

However we are running into a bug in PCRE versions prior to v8.10 while trying to upgrade to LimeSurvey 2.00+.

Has anyone tried upgrading PCRE on their RHEL 6 servers? Did you have to compile from source, and did you have any dependency problems?

share|improve this question
    
Is that bug present in RHEL? The version they report might be 7.8, but probably with patches and backports so it's mother wouldn't recognize it. Have you taken the issue up with Red Hat? –  vonbrand Feb 20 '13 at 17:32
    
I'd shy away from updating outside standard Rhat supported packages, you'll lose your support on this stuff and be on your own in the event of problems. Be advised that Rhat does backport things put not change the version numbers. –  mdpc Feb 20 '13 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.