Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Installing par packer in solaris 11 is throwing following error. i had used perlgcc but didnt help Has anyone faced the similar issue? How can i install it successfully

# perlgcc Makefile.PL
# make
Skip blib/lib/PAR/Packer.pm (unchanged)
Skip blib/lib/PAR/StrippedPARL/Base.pm (unchanged)
Skip blib/lib/PAR/Filter/Obfuscate.pm (unchanged)
Skip blib/lib/PAR/Filter/PodStrip.pm (unchanged)
Skip blib/lib/App/Packer/PAR.pm (unchanged)
Skip blib/lib/PAR/Filter.pm (unchanged)
Skip blib/lib/PAR/Filter/PatchContent.pm (unchanged)
Skip blib/lib/PAR/Filter/Bytecode.pm (unchanged)
Skip blib/lib/pp.pm (unchanged)
Skip blib/lib/PAR/Filter/Bleach.pm (unchanged)
gcc -c -DPTR_IS_LONG -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DPERL_USE_SAFE_PUTENV  -I/usr/perl5/5.12/lib/i86pc-solaris-64int/CORE  -DPARL_EXE=\"parl\" -xO4 main.c
gcc: language O4 not recognized
gcc: language O4 not recognized
gcc: main.c: linker input file unused because linking not done
cc main.o -s   -R /usr/perl5/5.12/lib/i86pc-solaris-64int/CORE  -L/usr/lib -L/usr/ccs/lib  -L/lib -L/usr/gnu/lib   -L/usr/perl5/5.12/lib/i86pc-solaris-64int/CORE -lperl -lsocket -lnsl -ldl -lm -lc -o ./par
cc: main.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `par'
Current working directory /export/home/tzenoss/PAR-Packer-1.014/myldr
*** Error code 1
The following command caused the error:
cd myldr && make -f Makefile all LIBPERL_A="libperl.a" LINKTYPE="dynamic" OPTIMIZE="-xO4" PREFIX="/usr/perl5/5.12"
make: Fatal error: Command failed for target `subdirs'
share|improve this question
    
just use gmake instead of make. –  Tim Kennedy Feb 22 '13 at 17:51
    
@TimKennedy tried gmake but was throwing the same error –  LINUX4U Feb 23 '13 at 2:43
add comment

1 Answer

up vote 1 down vote accepted

It looks like the makefile is trying to use -x04 which is an optimization flag for Solaris cc compiler. However, since you're using gcc and not Solaris cc, gcc doesn't understand the flag and thus doesn't know how to compile main.o for you.

In other words, it should work if you use the Solaris cc to compile instead of gcc. If you do want to use gcc, make sure that the Makefile.pl reflects that.

share|improve this answer
    
thanks i downloaded solarisstudio compiler package and i was able to sort the issue.your reply had given some insight to the issue. –  LINUX4U Feb 22 '13 at 9:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.