Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

last week i bought dedicated server called SP in OVH offer. I can't configure its correctly.

My parameters is:

RAM 32 GB Cores 4 Threads 8 Hard drive 2x 120GB SSD Connection 100 Mbps

moreg about dedicated server here: enter link description here

My apache2.conf file:

<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75 
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

When traffic is above 500 users online, my pages (link) fault but server is OK. I use wordpress 3.2 with wp quick cache.

Cpu < 1-10%, Memory < less 2 GB, Disck busy < 1-10% Connection 14Mbps

I installed page speed (Google) I disabled mod: headers, mod_authz, expires, deflate, setenvif, autoindex

share|improve this question
2  
Is there a question in there? –  MadHatter Feb 21 '13 at 9:35
    
What does "my pages fault" mean? –  Jenny D Feb 21 '13 at 9:41
    
My pages fault mean Pages doesn't work. A server response time rapidly grow from 0.2 to 3 seconds and loading page from 6s to 16 seconds. A question is how configure apache2.conf for my dedicated server. –  EliaszKubala Feb 21 '13 at 9:48
    
You've got configurations for both Worker and Prefork, which MPM are you actually using?? 6+ seconds for a webpage is insane; I'd be grumpy if my server took more than 1 second to load the page and all the elements in it. –  Chris S Feb 21 '13 at 14:35

3 Answers 3

up vote 1 down vote accepted

When traffic is above 500 users

According to your config, you have MaxClients set at 150. Check if you're hitting your MaxClients limit in the Apache error log, depending on your distribution it can be in a few places:

  • /var/log/httpd/error_log
  • /var/log/apache2/error.log

If you are hitting MaxClients and your server isn't maxing it's resources then it's probably safe to raise the limit a bit. All of this needs to be monitored and adjusted over time as resource usage heavily depends on your application code and it's not really possible to say 'here's a config for a server with 32GB RAM, etc'.

You can read more about common Apache directives here.

share|improve this answer
    
My error log is clear. –  EliaszKubala Feb 21 '13 at 10:09
    
Today i will try raise MaxClients. –  EliaszKubala Feb 21 '13 at 10:18
    
Here is a lot of helpful stuff rc3.org/2012/12/29/setting-apache-maxclients-for-small-servers –  EliaszKubala Jan 19 at 21:37

Apart from Jake Stubbs's answer, you might also want to have a look at your MySQL logs and settings. The delay could also be due to the SQL server not responding quickly enough to a large number of queries.

share|improve this answer
    
I have WP Quick Cache Plugin. My MySQL is used only when i Clearing Cache (at 8 pm). –  EliaszKubala Feb 21 '13 at 10:11

When traffic is above 500 users

This is a meaningless metric.

but server is OK

Again this is pretty meaningless.

Both the apache configurations looks very poor - what have you tried to resolve the problem? You might want to start by finding out if you are running the pre-fork or LWP server. Really you should probably be using the pre-fork. I'd suggest starting with:

StartServers         20
MinSpareServers      10
MaxSpareServers      20
MaxClients          300
MaxRequestsPerChild 1000

Make sure you've got Keepalives enabled with a timeout of 2 or 1.

How is your PHP connected to the webserver (should be mod_php).

I installed page speed (Google)

Do you mean mod_pagespeed? Why?

I disabled mod: headers, mod_authz, expires, deflate, setenvif, autoindex

Why? Put mod_deflate back AND CONFIGURE IT TO COMPRESS ALL your html, css, javascript and PHP output.

Put mod_headers and mod_expires back - you need them to configure caching properly - then configure approriate caching.

Next, disable mod_pagespeed and tune your webserver.

Next install and configure an opcode cache.

Then install and configure w3 total cache.

Once you've got all this running optimally add a reverse proxy (varnish or nginx) and enable mod_pagespeed again - but this time tune it properly.

share|improve this answer
    
It's mean 500+ users online. I have 50 000 daily visits. Thanks for the reply. –  EliaszKubala Feb 21 '13 at 14:10
    
That's less than 2 hits per second (assuming a normal 8 hour activity period per day). A cell phone should be able to run that website. –  Chris S Feb 21 '13 at 14:32
    
More than 15 hits per seconds. –  EliaszKubala Feb 21 '13 at 14:34
    
You've got numbers all over the place... 15 hits per second => 54,000 per hour; and close to 0.5 MM per day. –  Chris S Feb 21 '13 at 14:55
    
@EliaszKubala: repeating the numbers doesn't mean they make more sense. While the number of online users can have a slight impact on performance when using a memory based session handler its got NOTHING to do with the load on the server - which is all about concurrent connections and the nature of those connections. –  symcbean Feb 21 '13 at 17:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.