Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Oracle VM VirtualBox Manager v4.2.0 r80737 on Microsoft Windows 7 and aiming to set up a bridged network to my Debian Linux 6.0 Virtual Machine to be able to connect to it via Local Network and to have Internet access on it. It was working correctly yesterday, but today it failed.

When I use the command ifup eth0, it keeps waiting for the DHCP. It outputs:

DHCPDISCOVER on eth0 to port 67 interval 6
DHCPDISCOVER on eth0 to port 67 interval 14
DHCPDISCOVER on eth0 to port 67 interval 13
DHCPDISCOVER on eth0 to port 67 interval 15
DHCPDISCOVER on eth0 to port 67 interval 13

My /etc/network/interfaces file contains the following code:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

Any ideas what I could be doing wrong?

share|improve this question

closed as off topic by Michael Hampton, mdpc, EEAA, Khaled, Tom O'Connor Feb 23 '13 at 12:25

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 1 down vote accepted

If all you want is internet access in the guest machine, NAT will work out-of-the-box, no need for a bridge. You can use that together with Shared Forlders for sharing files between the host and the quest OS.

If you really want a bridge, e.g. you want to appear as two different hosts for other systems in your local network, while still being able to ssh to the guest, you should probably set up a bridge though. If VirtualBox Manager won't do it to you automatically, you can bridge the virtual NIC associated with your guest OS with another network interface in Network Adapter Settings on your host OS (check to see first if they are already birdged).

If you're still not getting any DHCP offers on the guest OS, try to set an IP manually and then ping your DHCP server (e.g. your router or modem), also from the guest OS, to see if you can access the network.

share|improve this answer
Thank you for your answer. In which network does my guest OS need to be if I would try to set up a static IP? The same network as my Host? Or does bridging create a different network? – user907560 Feb 21 '13 at 14:42
Bridging will use the same network, it does not create a different network. So if your router/modem is, your host OS is, say,, you can set the guest OS to and then try network access. – Attila O. Feb 21 '13 at 14:47
It worked! However, other computers on the same local network are not able to ping me. Do you know why? – user907560 Feb 21 '13 at 16:05
@user907560 that's odd, do you see the network bridge in Network Adapter Settings in your Windows 7 host? Check its properties to see if maybe ICMP packets are being blocked somehow. (I assume you're using the bridge mode, not NAT, right?) – Attila O. Feb 21 '13 at 16:08
Not sure where to find settings regarding ICMP. My VirtualBox Host-Only Network is on a different network (192.x.x.x) than the Guest OS and my Host OS though (145.x.x.x). Should I enabled Internet Connection Sharing (ICS)? – user907560 Feb 21 '13 at 16:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.