Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using WHM 11.34.1 (build 7) on a VPS running CentOS 5.3. I have created an account and uploaded a website to it. When I upload a file using PHP file the server lays out error 500.

I have checked the file permissions but nothing so far.I have no idea why the access log is not being written to.

I have already tried the following: (my server is running CGI/FastCGI)

MaxRequestLen 15728640

Update 1 File upload is on and the ini value for max post size are set correctly. I cannot upload even the smallest file.

share|improve this question
    
try increasing max upload size in php settings or check you have enough space –  sharif Feb 21 '13 at 15:18
    
I have already done so and that did not solve the problem. I am uploading an 80kb image where the post size is 25MB –  thedethfox Feb 21 '13 at 15:24
    
post_max_size and upload_max_filesize and check to see your file uploads is on? –  sharif Feb 21 '13 at 15:44
    
please post the relevant lines from /var/log/httpd/error_log. –  Daniel t. Feb 21 '13 at 18:06
    
I have just found the problem. So thanks anyways. No errors were being written to the log file and that's why I was confused. –  thedethfox Feb 21 '13 at 18:38
add comment

1 Answer 1

I have just found the issue. GD library was missing. I have recompiled PHP with GD and it worked like a charm.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.